GiorgioFoX
Posts: 5
Joined: Sun Jan 26, 2014 12:07 am

BadMatch on PI2

Wed Feb 04, 2015 10:08 pm

Hello,
I've followed this tutorial: http://www.rs-online.com/designspark/el ... nu-radio-2 to install GNU-RADIO COMPANION and some tools.

Every program that I try to use, for example just OSMOCOM_FFT give the error:
BadMatch (invalid parameter attributes) serial 1732 Error_code 8 request_code 70 minor_code 0

Also gnuradio-companion, or GQRX.

What can I do?
thanks
Giorgio

VinieBerry
Posts: 2
Joined: Thu Feb 05, 2015 6:13 pm

Re: BadMatch on PI2

Thu Feb 05, 2015 8:44 pm

I followed the same tutorial and I can run osmocom_fft without connecting yet any RF tuner. I will confirm that as soon as I installed the toolchain for the bladeRF.

GiorgioFoX
Posts: 5
Joined: Sun Jan 26, 2014 12:07 am

Re: BadMatch on PI2

Thu Feb 05, 2015 10:15 pm

It's strange!
You have download this?

Debian Wheezy
Version:January 2015
Release date:2015-01-31

Or the NOOBS 1.3.12?

I've tried both. Followed the tutorial, startx, open terminal and osmocom_fft give me the error.
Now I try on a new uSD, and I will try also to install bladeRF toolchain (can you please give me a link?)

thanks
Giorgio

GiorgioFoX
Posts: 5
Joined: Sun Jan 26, 2014 12:07 am

Re: BadMatch on PI2

Thu Feb 05, 2015 10:58 pm

I've just tried again:

Booted from a new microSD card, with another Raspberry PI 2 (I have two units here), and this is my steps:

Code: Select all

sudo nano  /etc/apt/sources.list
added deb http://archive.raspbian.org/raspbian jessie main

Code: Select all

sudo apt-get update
sudo apt-get install gnuradio gnuradio-dev
sudo apt-get install rtl-sdr gr-osmosdr
sudo reboot
then
startx -> open terminal -> osmocom_fft

and this is my error:
https://www.dropbox.com/s/gtvk1d8llv7x2 ... 9.jpg?dl=0

What I'm doing wrong?

I've tried with RTLs, HackRF and FCD+

thanks
Giorgio

GiorgioFoX
Posts: 5
Joined: Sun Jan 26, 2014 12:07 am

Re: BadMatch on PI2

Thu Feb 05, 2015 11:36 pm

Solved!

Code: Select all

sudo nano /boot/config.txt
and add
framebuffer_depth=32
framebuffer_ignore_alpha=1

VinieBerry
Posts: 2
Joined: Thu Feb 05, 2015 6:13 pm

Re: BadMatch on PI2

Fri Feb 06, 2015 6:44 am

Good :D

g0ukb
Posts: 1
Joined: Fri Feb 13, 2015 10:58 am

Re: BadMatch on PI2

Fri Feb 13, 2015 11:01 am

Giorgio - Thank You!! I was have a BadMatch error too and your fix fixed it for me.

it9ybg
Posts: 17
Joined: Tue Aug 27, 2013 7:08 pm
Location: Italy
Contact: Website

Re: BadMatch on PI2

Mon Jun 01, 2015 8:28 pm

I followed your guide, but I finally I have this error ... please help

Code: Select all

[email protected] ~ $ osmocom_fft
linux; GNU C++ version 4.9.1; Boost_105500; UHD_003.007.003-0-unknown

Traceback (most recent call last):
  File "/usr/bin/osmocom_fft", line 35, in <module>
    from gnuradio import blocks
  File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/__init__.py", line 34, in <module>
    from stream_to_vector_decimator import *
  File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/stream_to_vector_decimator.py", line 23, in <module>
    from gnuradio import gr
  File "/usr/lib/python2.7/dist-packages/gnuradio/gr/__init__.py", line 53, in <module>
    log.add_console_appender(prefs().get_string("LOG", "log_level", "off"), 'gr::log %d :%p: %m%n')
  File "/usr/lib/python2.7/dist-packages/gnuradio/gr/runtime_swig.py", line 3963, in singleton
    return _runtime_swig.prefs_singleton()
RuntimeError: locale::facet::_S_create_c_locale name not valid
'73 de Pepè (call:IT9YBG) :)
My blog: https://it9ybg.blogspot.com/

sac78008
Posts: 1
Joined: Fri Jul 10, 2015 6:10 pm

Re: BadMatch on PI2

Fri Jul 10, 2015 6:25 pm

@ ity9bg

I started out with your error (that's how I got to this page). After consulting der Google I found this workaround:
http://tech.enekochan.com/en/category/g ... x/page/15/
The error was solved by using this command:

export LC_ALL=C

But now I'm getting the "BadMatch" error and the config.txt edit didn't seem to fix it.

Anybody else get to stuck here? Help appreciated!

RP2bam
Posts: 1
Joined: Thu Apr 21, 2016 12:21 am

Re: BadMatch on PI2

Thu Apr 21, 2016 12:33 am

:P Thanx Giorgio I had the same problem with 2016-03-18-raspbian-jessie and osmocom_fft

Return to “Raspbian”