Posts: 5
Joined: Wed Jun 27, 2012 6:12 pm

USB MIDI input/output device not functioning

Wed Jun 27, 2012 6:24 pm


(Let me know if this should go in another forums / section...)

I have a USB midi input/output adapter. It's a cheap generic adapter that doesn't require a custom driver. It works on my desktop machine, with both Windows & Mint Linux. However it doesn't seem to be recognized by my Raspberry PI.

I'm running ArchLinux & initially with a system updated approximately 20 days ago. This recognized the USB device (when doing lsusb), but there was no /dev/midi1 device registered. Trying the steps suggested, failed at the step of "modprobe snd-seq". It gave an error of "FATAL: Module snd-seq not found.".

The device shows as the below in lsusb output (snapshot from my desktop)
Bus 003 Device 002: ID 4348:562d WinChipHead

I've now updated to the latest ArchLinux packages & it seems to hang the Raspberry Pi as soon as the adapter is inserted in to the USB Port. (I also tried & get the same result with the new Debian beta image, so I suspect it might be a change in firmware / usb packages that causes this behavior difference).

Any suggestions on how I can debug this further / other things to try? Is there any way to tell if the adapter is trying to use too much power over the USB port?

(FYI, I'm using this over SSH only rather, than running locally with keyboard/monitor).


Return to “Graphics, sound and multimedia”