chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

EDIMAX EW-7811UTC ac no up

Fri Dec 12, 2014 3:45 pm

Hi,

I bought EDIMAX EW-7811UTC for my rpi B+.

I update,upgrade, rpi-update; my kernel is 3.12.34+
When i plugged my dongle, there is not light and i can't ifup my wlan0

I tried different step like here: http://elinux.org/RPi_edimax_EW-7811Un but for 8812au chipset
no way

I can see my dongle:

Code: Select all

[email protected]:~/rtl8812au# lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 005: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
Bus 001 Device 006: ID 04f3:01a4 Elan Microelectronics Corp. Wireless Keyboard
Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd

I update my network:
nano /etc/network/interfaces to add the wlan0 section

# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
# /usr/share/doc/ifupdown/examples for more information.

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
pre-up wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant.conf -B

Code: Select all

nano /etc/wpa_supplicant/wpa_supplicant.conf to look like this:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=2
network={
  ssid="myssid"
  scan_ssid=1
  proto=RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP
  group=CCMP
  psk=”this is my secret phrase”
}
I install the new wifi driver in place of the one supplied in the Debian image, you need to add the new driver to the operating system and block the old one.

Code: Select all

    Copy the file 8812au.ko to the directory /lib/modules/3.12.34+/kernel/net/wireless.
    Add the line blacklist rtl8812au to /etc/modprobe.d/blacklist.conf.
    Add the line 8812au to /etc/modules so that wifi support is loaded at boot time.
    Run the command: depmod –a.
I tried to compile and I got this:

Code: Select all

[email protected]:~/rtl8812au# make
make ARCH=armv6l CROSS_COMPILE= -C /lib/modules/3.12.34+/build M=/root/rtl8812au  modules
make[1]: Entering directory '/lib/modules/3.12.34+/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/lib/modules/3.12.34+/build'
Makefile:1051: recipe for target 'modules' failed

could you help me please?

willseph
Posts: 2
Joined: Sat Dec 13, 2014 6:25 am

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 7:08 am

Hi chrysaoff, I found this thread because I ran into the same exact issue tonight on my own. My EW-7811UTC dongle would not work on my RPi B+ (or my other regular RPi B for that matter). I also had issues compiling the 8812au driver myself, but luckily I got it working. Hopefully this works as well for you.

First of all, trying to find a solution to the driver compilation issue, I found this post: http://www.raspberrypi.org/forums/viewt ... 65#p514365

After installing that package and executing the link described in that post, I was able to begin building the driver (with some warnings, though). Unfortunately, after attempting to insmod the driver, I got this error:

Error: could not insert module 8812au.ko: Invalid module format

Turns out the source I had downloaded for the driver (https://github.com/gnab/rtl8812au) was intended for another kernel version, whereas I am using 3.12.28+. By luck I stumbled on this thread (http://www.raspberrypi.org/forums/viewt ... 28#p625523), where I found a precompiled 8812au.ko driver for my kernel version.

After downloading that driver, I followed the instructions in that post to install and initialize it, and after some tweaking to make sure my wpa_supplicant.conf was correct, I was able to ifup wlan0 and the magic blue LED kicked on and everything started working!

chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 7:21 pm

willseph wrote:Hi chrysaoff, I found this thread because I ran into the same exact issue tonight on my own. My EW-7811UTC dongle would not work on my RPi B+ (or my other regular RPi B for that matter). I also had issues compiling the 8812au driver myself, but luckily I got it working. Hopefully this works as well for you.

First of all, trying to find a solution to the driver compilation issue, I found this post: http://www.raspberrypi.org/forums/viewt ... 65#p514365

After installing that package and executing the link described in that post, I was able to begin building the driver (with some warnings, though). Unfortunately, after attempting to insmod the driver, I got this error:

Error: could not insert module 8812au.ko: Invalid module format

Turns out the source I had downloaded for the driver (https://github.com/gnab/rtl8812au) was intended for another kernel version, whereas I am using 3.12.28+. By luck I stumbled on this thread (http://www.raspberrypi.org/forums/viewt ... 28#p625523), where I found a precompiled 8812au.ko driver for my kernel version.

After downloading that driver, I followed the instructions in that post to install and initialize it, and after some tweaking to make sure my wpa_supplicant.conf was correct, I was able to ifup wlan0 and the magic blue LED kicked on and everything started working!
Thanks but my kernel is 3.12.34+ so I didn't find a 8812au.ko compiled

I tried with 3.12.33+ but it is not working

I did:

Code: Select all

wget https://www.dropbox.com/s/lwn9irdeixj5oui/8812au-3.12.33%2B_no_ps-4.2.2.ko?dl=0

Code: Select all

mv 8812au-3.12.33%2B_no_ps-4.2.2.ko 8812au.ko
sudo install -p -m 644 8812au.ko /lib/modules/3.12.34+/kernel/drivers/net/wireless
sudo depmod -a
sudo insmod 8812au.ko
nano /etc/network/interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
# allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp
nano /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="your_ssid"
psk="your_wifi_password"
proto=WPA
key_mgmt=WPA-PSK
pairwise=TKIP
auth_alg=OPEN
}
ifup wlan0
wlan0 failed

and now, my RPI doesn't want to get an IP address by Ethernet, so impossible to use by SSH in my computer

after ifup eth0, i found back but still not wlan0

I got this error:

/sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
...
Cannot find device wlan0
failed to bring up wlan0

I will wait the 8812au.ko and try again, i hope it will be ok
:(

willseph
Posts: 2
Joined: Sat Dec 13, 2014 6:25 am

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 7:53 pm

chrysaoff wrote:sudo install -p -m 644 8812au.ko /lib/modules/3.12.34+/kernel/drivers/net/wireless
sudo depmod -a
sudo insmod 8812au.ko
Did you get any errors after running this? If not, you might want to check your running modules (lsmod) to see if it's showing up. My list is as follows:

Code: Select all

Module                  Size  Used by
8192cu                550797  0 
snd_bcm2835            19584  0 
snd_soc_bcm2708_i2s     6202  0 
regmap_mmio             2818  1 snd_soc_bcm2708_i2s
snd_soc_core          127841  1 snd_soc_bcm2708_i2s
snd_compress            8259  1 snd_soc_core
regmap_i2c              1661  1 snd_soc_core
snd_pcm_dmaengine       5505  1 snd_soc_core
8812au               1098934  0 
regmap_spi              1913  1 snd_soc_core
snd_pcm                83845  3 snd_bcm2835,snd_soc_core,snd_pcm_dmaengine
snd_page_alloc          5132  1 snd_pcm
snd_seq                55484  0 
snd_seq_device          6469  1 snd_seq
snd_timer              20998  2 snd_pcm,snd_seq
leds_gpio               2079  0 
led_class               4118  1 leds_gpio
snd                    62252  7 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_seq,snd_seq_device,snd_compress
Before installing the 8812au.ko driver, the module 8812au, wasn't showing up. If you see that in your list, I think that the module actually is working, in which case it may just be an issue with your /etc/network/interfaces or wpa_supplicant.conf files.

Here are those files running on my pi, with wlan0 working and everything:

/etc/network/interfaces

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
    wireless mode managed
    wireless essid any
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
allow-hotplug wlan0
/etc/wpa_supplicant/wpa_supplicant.conf

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="MY SSID"
        psk="MY WPA2 PASSWORD"
}
Try updating your files to match mine (with your correct SSID and WPA key, of course) and see if you can do an ifup wlan0 afterwards.

If, however, the 8812au module isn't showing up after lsmod then the driver still isn't working, I assume. In which case it looks like you may need to wait for plowna to supply you with the driver for your kernel version in that other thread. Hopefully you can get this working soon!
Last edited by willseph on Sat Dec 13, 2014 9:06 pm, edited 1 time in total.

chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 10:42 pm

Try updating your files to match mine (with your correct SSID and WPA key, of course) and see if you can do an ifup wlan0 afterwards.

I did exactly like you

my lsmod:

Code: Select all

[email protected]:~# lsmod
Module                  Size  Used by
8812au                951898  0
bcm2708_wdog            3545  1
ipv6                  316254  23
xt_state                1174  1
iptable_mangle          1514  0
iptable_nat             2607  0
nf_conntrack_ipv4      12965  2
nf_defrag_ipv4          1491  1 nf_conntrack_ipv4
nf_nat_ipv4             3630  1 iptable_nat
nf_nat                 15166  2 nf_nat_ipv4,iptable_nat
nf_conntrack           87622  5 nf_nat,xt_state,nf_nat_ipv4,iptable_nat,nf_conntrack_ipv4
iptable_filter          1485  1
ip_tables              11694  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               17030  4 ip_tables,xt_state,iptable_filter,iptable_mangle
snd_soc_pcm512x         9034  0
snd_soc_wm8804          7932  0
snd_soc_tas5713         5573  0
evdev                  10681  0
joydev                  9257  0
leds_gpio               2079  0
led_class               4118  1 leds_gpio
snd_soc_bcm2708_i2s     6210  0
regmap_mmio             2818  1 snd_soc_bcm2708_i2s
snd_soc_core          127849  4 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_tas5713,snd_soc_bcm2708_i2s
snd_compress            8259  1 snd_soc_core
regmap_i2c              1661  4 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_core,snd_soc_tas5713
snd_pcm_dmaengine       5505  1 snd_soc_core
regmap_spi              1913  3 snd_soc_pcm512x,snd_soc_wm8804,snd_soc_core
snd_pcm                83845  2 snd_soc_core,snd_pcm_dmaengine
spi_bcm2708             4964  0
snd_page_alloc          5132  1 snd_pcm
snd_timer              20998  1 snd_pcm
i2c_bcm2708             4943  0
snd                    62252  4 snd_soc_core,snd_timer,snd_pcm,snd_compress
so you can see;,i have

and still this problem:

Code: Select all

[email protected]:~# ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Cannot find device "wlan0"
Bind socket to interface: No such device
Failed to bring up wlan0.
I will wait the update for 34+

thanks @willseph

User avatar
DougieLawson
Posts: 36331
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 11:23 pm

chrysaoff wrote:
I will wait the update for 34+
sudo rpi-update will get you to 3.12.34+ right now.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

Re: EDIMAX EW-7811UTC ac no up

Sat Dec 13, 2014 11:57 pm

DougieLawson wrote:
chrysaoff wrote:
I will wait the update for 34+
sudo rpi-update will get you to 3.12.34+ right now.
my kernel is already updated with 3.12.34+.
I spoke about the driver ^^ but thanks

User avatar
DougieLawson
Posts: 36331
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: EDIMAX EW-7811UTC ac no up

Sun Dec 14, 2014 12:05 am

There was an update today that didn't include a new kernel (so it is still 3.12.34+) but did include some extra modules for WiFi adapters.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

Re: EDIMAX EW-7811UTC ac no up

Sun Dec 14, 2014 12:47 am

yes but apparently i didn't receive that:

Code: Select all

[email protected]:~# sudo -E RPI_UPDATE_UNSUPPORTED=0 rpi-update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Performing self-update
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  7811  100  7811    0     0  19997      0 --:--:-- --:--:-- --:--:-- 33380
 *** Relaunching after update
 *** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
 *** Your firmware is already up to date

chrysaoff
Posts: 12
Joined: Sun Nov 16, 2014 9:54 pm

Re: EDIMAX EW-7811UTC ac no up

Sun Dec 14, 2014 1:10 pm

So, I have half success

I made update,upgrade,dist-upgrade,

Code: Select all

sudo apt-get update
sudo apt-get upgrade
sudo rpi-update
sudo -E RPI_UPDATE_UNSUPPORTED=0 rpi-update
I checked my linux-kernel first:

Code: Select all

uname -r
3.12.34+
download the driver compiled for 3.12.34+
thanks to @willseph
http://www.raspberrypi.org/forums/viewt ... 28#p625523

Code: Select all

wget https://www.dropbox.com/s/eub0lg913nvco6k/8812au-3.12.34%2B_no_ps.ko?dl=0
Move in the folder wireless:

Code: Select all

mv 8812au-3.12.34%2B_no_ps.ko 8812au.ko
cp 8812au.ko /lib/modules/3.12.34+/kernel/drivers/net/wireless
Install:

Code: Select all

sudo install -p -m 644 8812au.ko /lib/modules/3.12.34+/kernel/drivers/net/wireless
sudo depmod -a
sudo insmod 8812au.ko

Checked the network conf:

Code: Select all

nano /etc/network/interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
# allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp
Put the right SSID and wpa2 password:

Code: Select all

nano /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="MY SSID"
        psk="MY WPA2 PASSWORD"
}
And to apply the settings, reboot

Code: Select all

sudo reboot
Now, I can see my dongle with the blue light and can ifup wlan0
But I dont have an address IP.
I have my OS in RASPBMC, access-point with Asus RT-AC66U with the mode AP and my box in DHCP.

When I restart my RPI, i need to ifup wlan0 everytime.
How to fix this issue?

thanks for your help to detect my dongle edimax

jaodnam
Posts: 1
Joined: Thu Feb 19, 2015 5:11 am

Re: EDIMAX EW-7811UTC ac no up

Thu Feb 19, 2015 5:15 am

any chance someone has found a fix for the rpi 2?

Return to “Troubleshooting”