Stankyz
Posts: 2
Joined: Sat Jun 23, 2012 2:12 pm

PANIC: VFS: Unable to mount root fs on unknown-block(179,2)

Sat Jun 23, 2012 2:22 pm

Hi,

After ~5 boots my Raspberry Pi:
PANIC: VFS: Unable to mount root fs on unknown-block(179,2)
Entering kdb (current=oxc7848c80, pid 1) due to Keyboard Entry
kdb >

It's not the first time, i already use 3 SD card with the latest kernel.

Install apache, reboot, install PHP, reboot, install MySQL, reboot, install no-ip, reboot. And *tadam* PANIC: VFS: Unable to mount root fs on unknown-block(179,2) !

- No keyboard
- No mouse
- No hdmi

(Only use ssh)
With or without ethernet, doesn't make any change ...
.IMG = debian6-19-04-2012 from http://www.raspberrypi.org/downloads

SD:
- Emtec SDHC 4GB Class 4
- Dance-Elec 2GB Class 4
- Intenso SDHC 4GB Class 4

What should I do ? I can't format every 5 boots !

I guess it's a bug with the damn filesystem ext4 ? :D


Regards,

Stankyz

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5398
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Sat Jun 23, 2012 2:48 pm

what does
uname -a
report? How are you rebooting?

I'd recommend using the Wheezy image:
http://www.raspberrypi.org/archives/1435

Stankyz
Posts: 2
Joined: Sat Jun 23, 2012 2:12 pm

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Sat Jun 23, 2012 2:58 pm

what does
uname -a
Nothing ... Can't type in kdb >
report? How are you rebooting?
In ssh I used sudo reboot ...
I'd recommend using the Wheezy image:
http://www.raspberrypi.org/archives/1435
Gonna try ,thx ! :)

EtiGre
Posts: 13
Joined: Tue Jun 12, 2012 9:21 am

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Fri Jun 29, 2012 2:02 pm

Hi Stankyz,

Just to let you know, I found out your post because I see the exact same problem on my Pi.
I'm using the Wheezy Debian on a Sony SD card and if I electrically reboot the Pi (not with a clean shutdown -r), I'm sure to get a SD card corruption with the same message!

My solution so far: create a backup of my filesystem and "dd" it back at each reboot...


Cheers,
Eti

User avatar
RaTTuS
Posts: 10532
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Fri Jun 29, 2012 2:07 pm

I've seen this on my system where I have the rootfs mounted on a USB HD - powercycling the USB HD fixes it.
I think something is not being cleanly flushed on reboot.

check your power.
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

ndpmcintosh
Posts: 11
Joined: Thu Jul 12, 2012 7:08 pm

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Thu Jul 12, 2012 7:18 pm

So what is the "real" solution to this problem?

I used RasPiWrite to set up my SD card. Tried it with Debian Squeeze, tried to use Debian Wheezy (but I couldn't get RasPiWrite to install it properly), and I just tried Fedora (installed with RasPiWrite) but its the same result every time. It makes no difference if I have a keyboard hooked up or not. I'm dead in the water and the RsP will not boot.

Any suggestions?

ndpmcintosh
Posts: 11
Joined: Thu Jul 12, 2012 7:08 pm

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Fri Jul 13, 2012 2:19 pm

Well, I solved my kernel panic (179,2) problem by not using a cheap (probably counterfeit) SD card delivered by boat from Hong Kong. Lesson learned.

mattanl
Posts: 143
Joined: Thu Jun 14, 2012 10:40 am

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Sat Sep 15, 2012 10:10 am

I've found your message after having the same issue.
I bought SanDisk SDHC 16GB class 4 (which is verified).
I could buy the class 10 but I understood that these cards have problems with the raspi.
Can you recommend which card to buy?
Thanks.

cashlee
Posts: 1
Joined: Fri Mar 01, 2013 5:44 pm
Location: China/Canton
Contact: Website

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Fri Mar 01, 2013 5:53 pm

Oh my god.It seems that not myself's problem.I installed many things tonight and I use ssh to reboot my Raspberry Pi.

After that I found that I can't ssh to login into my Raspberry Pi.So I connect Pi with my monitor.I saw the same things kdb> .... .And the system did't work again.

Finally I tried to clean up the SD card on my Mac.But Macbook gave me many errors.

I think that I should go to buy a new SD card for Raspberry Pi.SAD. :cry:

leeiio
Posts: 2
Joined: Sat Mar 02, 2013 1:12 am

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Sat Mar 02, 2013 1:18 am

I've also seen this on my Pi when I have the rootfs mounted on a USB HD, sometimes not very often.You can try to remove your USB HD and check whether the problem is not see again.
I don't know whether is my SD card's problem. My SD card is SanDisk 8GB Class10 UHS1.
Now everything is ok :mrgreen:

sidebarr
Posts: 1
Joined: Sun Apr 07, 2013 4:09 pm

Re: PANIC: VFS: Unable to mount root fs on unknown-block(179

Sun Apr 07, 2013 4:20 pm

Hi,
I had this same problem. As near as I am able to figure, it occurred because I unplugged my pi too soon after shutting down. I reflashed the the SD Card (Kingston 8gb, class10) with raspbian wheezy. I now use sudo poweroff in the terminal and wait until my TV/monitor says "No Signal" before I unplug the pi. I haven't had a problem since. I hope this helps someone.

Return to “Troubleshooting”