Arto1234
Posts: 18
Joined: Mon Aug 25, 2014 4:28 pm

sakis3g, PIN error

Mon Aug 25, 2014 4:32 pm

I try to connect to the internet by using sakis3g script. I had downloaded its sources from here: https://github.com/trixarian/sakis3g-source, and compiled it in RPi. I followed the instructions in the site for compilation and then launched sakis3g accordingly (sudo ./sakis3g -interactive -noprobe).
An error box shows with the following error message, "Modem responded "ERROR" while checking for PIN".

I have a Huawei E367 3G modem which lsusb reports as a Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM modem Networkcard.

usb_modeswitch works ok. 3G dongle gets switched from 12d1:1446 to 12d1:1506.

Can you help with this? How to get the PIN communicated correctly?
Only thing that the sakis3g script can do, is the tty check (menu option 3).

Trixarian
Posts: 1
Joined: Sat Sep 20, 2014 7:26 pm

Re: sakis3g, PIN error

Sat Sep 20, 2014 7:31 pm

You can either put the sim card in a normal mobile phone and disable the pin or you can provide your pin for switching in /etc/sakis3g.conf using the SIM_PIN="" variable. See this link for more information on it.

alkopop79
Posts: 50
Joined: Thu Mar 08, 2012 7:10 pm
Location: London

Re: sakis3g, PIN error

Mon Sep 29, 2014 12:14 pm

Trixarian wrote:You can either put the sim card in a normal mobile phone and disable the pin or you can provide your pin for switching in /etc/sakis3g.conf using the SIM_PIN="" variable. See this link for more information on it.
I have the same problem as the OP even after adding SIM_PIN="" or SIM_PIN="0000". Any workaround?

iacob_petrescu
Posts: 1
Joined: Mon Aug 29, 2016 10:40 pm

Re: sakis3g, PIN error

Mon Aug 29, 2016 10:43 pm

You need to start the modem. There are two buttons next to the antenna. Press the power key.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 68 guests