petoetje59
Posts: 15
Joined: Thu Aug 07, 2014 4:24 pm

Wrong keyboard layout using XRDP

Thu Aug 07, 2014 4:41 pm

Hi all,

I'm trying to use a headless RPi - i.e. connected only to a network cable and using a desktop PC.
SSH using PuTTY works fine, my non-US keyboard works as expected (probably because PuTTY runs on Windows).
However, when I try to use XRDP using Remote Desktop Connection from Windows, it reverts back to the US keyboard layout - making text input unusable.
All the tutorials I found about how to set up a headless RPi never mention this problem (probably because the authors use a US keyboard), and an advanced search with keywords "keyboard" + "XRDP" turns up nothing in this forum.

How to fix this ?

Petoetje59.

User avatar
mad-hatter
Posts: 419
Joined: Sun Feb 26, 2012 2:58 pm
Location: By the UK seaside

Re: Wrong keyboard layout using XRDP

Thu Aug 07, 2014 8:30 pm

Hello,

I had the same problem, after searching google, a windows registry change seems to be the solution.
I can't remember what I changed, but google has the answer.

Regards

petoetje59
Posts: 15
Joined: Thu Aug 07, 2014 4:24 pm

Re: Wrong keyboard layout using XRDP

Thu Aug 07, 2014 10:03 pm

mad-hatter wrote:Hello,

I had the same problem, after searching google, a windows registry change seems to be the solution.
I can't remember what I changed, but google has the answer.

Regards
Has nothing to do with Windows, but everything with XRDP which is a Linux program.
I gave up, removed the immature unproven XRDP, and am using the proven TightVNCserver instead which has the same functionality and no keyboard issues.

stuart258
Posts: 1
Joined: Sun Sep 06, 2015 2:49 pm

Re: Wrong keyboard layout using XRDP

Sun Sep 06, 2015 3:01 pm

Hello Everyone,
I'm having the same problem as the OP but I'd prefer to stick with RDP as I understand (a) it's more secure than VNC, and (b) the performance is better - and I want to connect over the internet as well as a local network.

I found this page (http://component-parts.blogspot.co.uk/2 ... -xrdp.html) which explains what to do... but it doesn't work (even though the first reply says it's fine for an RPi). I've followed the instructions but there's no change. I'm brand new to Linux and the RPi but I don't think I've made any mistakes... It feels as though xrdp simply isn't looking for the 0809 file - should it find it automatically after restarting?

The only idea I've got is that my keyboard on the Windows PC is set to UK-Extended but I've tried switching to standard UK and that didn't help.

For now I've followed someone else's suggestion to rename the UK file (0809) as the US file (0409) and that's working fine but it feels like a bit of a hack!

Any suggestions would be appreciated.

Thanks.
Stuart.

Return to “General discussion”