kraymitchell
Posts: 33
Joined: Tue Feb 25, 2014 9:50 pm
Location: Canada
Contact: Website

EXT4-fs error (device mmcblk0p2): __ext4_journal_start_sb:62

Mon Jun 23, 2014 2:27 pm

On Friday I did a fresh install of Raspbian on a 16GB Class 10 card. I left it running at Raspi-Config (Ended up getting sent home early due to network issues and simply forgot) and when I came back today, I had the following on the screen. This was hand typed from the screen, so there may be some typos.

Anybody know what this all means? Something I need to be concerned about? Thanks in advance.

Code: Select all

[14374.179834] EXT4-fs error (device mmcblk0p2): __ext4_journal_start_sb:62: Detected aborted journal
[14374.189112] EXT4-fs error (mmcblk0p2): Remounting filesystem read-only
[14400.344538] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #212: comm udevd: reading directory lblock 0
[14400.365041] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #2: comm udevd: reading directory lblock 0
[14400.385676] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #212: comm udevd: reading directory lblock 0
[14400.403632] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #213: comm udevd: reading directory lblock 0
[14400.279055] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #6073: comm cron: reading directory lblock 0
[14400.892583] EXT4-fs error (device mmcblk0p2): ext4_find_entry:1309: inode #14: comm ntpd: reading directory lblock 0
Sometimes a teacher, always a student.
Failure is my homeboy
iThink, therefore iMac.

User avatar
RaTTuS
Posts: 10241
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: EXT4-fs error (device mmcblk0p2): __ext4_journal_start_s

Mon Jun 23, 2014 2:41 pm

possibly a power problem - how are you powering it all?
what happens when you rebnoot
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

kraymitchell
Posts: 33
Joined: Tue Feb 25, 2014 9:50 pm
Location: Canada
Contact: Website

Re: EXT4-fs error (device mmcblk0p2): __ext4_journal_start_s

Mon Jun 23, 2014 2:53 pm

I've been using an adaptor from Adafruit as well as this adaptor from MonoPrice (http://www.monoprice.com/Search/Index?k ... ll+charger) without any issues.

Nothing happened on reboot. I pulled the card adaptor and microSD and reseated everything and restarted without issue.
Sometimes a teacher, always a student.
Failure is my homeboy
iThink, therefore iMac.

serano
Posts: 5
Joined: Fri Jan 04, 2013 10:14 am

Re: EXT4-fs error (device mmcblk0p2): __ext4_journal_start_s

Fri Apr 22, 2016 4:33 pm

I can confirm what the above person said. I have bought the exact same card and am running into the same issues with libc6-dev:armhf

Everything runs smooth but as soons as you dare to upgrade the EXT4-fs crashes. This causes the freezing remarked by the other uses.

The exact error that first comes up: EXT4-fs (mmcxxxxxx): Delayed block allocation failed for inode 18379 at logical offset 0 with max blocks 8 with error 5.

I have tried repairing with fsck but no luck (superblock errors were given) on a second system, and some other actions but nothing helps.

thebeachtoday
Posts: 8
Joined: Wed Mar 22, 2017 11:49 pm

Re: EXT4-fs error (device mmcblk0p2): __ext4_journal_start_s

Thu Jun 01, 2017 11:18 am

I just spent a half day figuring this out. First, make sure that /boot/config.txt has

Code: Select all

max_usb_current=1
at the top...that was not the root cause for me though. I was using hostapd with the onboard wlan0 set as an ap with no Ethernet connection. That is, the onboard wlan0 acted as the internet gateway as well as the AP for hotspot via hostapd. Anyways, what worked for me was discussed on Arch Linux here: https://archlinuxarm.org/forum/viewtopi ... 9&start=10, and resolved it for me. The code:

Code: Select all

sudo sysctl net.ipv4.tcp_early_retrans=0

Return to “Troubleshooting”