bfinio
Posts: 38
Joined: Mon Oct 14, 2013 8:53 pm

WiFi adapter working in regular Raspbian but not RetroPie

Sun Jan 26, 2014 8:01 pm

Hi - this is a bit of a length post, but I'm trying to be as detailed as possible in reproducing what I've done to get to this point. Any help will be appreciated.

I have two very similar RPi setups - one for work and one for play. The "work" version is running a pretty recent version of Raspbian (downloaded sometime in December, I haven't updated it recently and I'm not actually sure how to look up the current version I have installed), and the "play" version is running RetroPie, with the SD card image downloaded from http://blog.petrockblock.com/retropie/r ... downloads/.

I initially had the "work" version hardwired to my router, but I purchased the very popular Edimax EW-7811Un USB wifi adapter, http://www.amazon.com/gp/product/B003MTTJOY/, for the RetroPie setup, because I'd like to occasionally use it to boot into the normal Raspbian desktop environment and do other things. I also bought a powered USB hub, http://www.amazon.com/gp/product/B003Z4G3I6/, since this would require two USB game controllers in addition to the WiFi and keyboard/mouse dongles. I'm using a Logitech K400 mouse/keyboard combo for both setups.

I initially tried booting up into the desktop environment on the RetroPie machine and using the wireless setup GUI, wpa_gui, to connect to my home wireless router. However, no networks appeared at all in the "Scan" option. I tried to manually add my router (Manage Networks -> Add) and immediately ran into a similar problem as this thread: http://www.raspberrypi.org/phpBB3/viewt ... 28&t=20535, where the "Current Status" tab freaked out and would bounce between "Scanning" and "4-way handshake". I spent a lot of time Googling this and found many other threads where people were surprised to find that the supposedly reliable Edimax adapter wasn't working, but no clear solutions. Using an externally powered USB hub, I was pretty sure power wasn't the issue - even then, most posts I've seen claim that the Edimax adapter can run straight off one of the Pi's USB ports.

So, just to be sure, I tried switching the WiFi adapter over to the regular Raspbian machine (right into the USB port, no hub). That worked like a charm on the first try. I went into wpa_gui, my home network showed up in the scan, and I was able to add it and get internet access with no trouble. So, I know the Edimax adapter works, and is capable of connecting a Raspberry Pi to my home router.

Back to the RetroPie machine. I thought that maybe, for whatever reason, the powered USB hub was screwing things up (too many devices plugged into one hub?), so I got rid of that and just plugged the Logitech keyboard and Edimax adapter directly into the Pi's USB ports, exactly as I had on the Raspbian machine. Still no luck - now it wouldn't even detect my home network at all using the scan function.

Next debugging step: to make sure there wasn't something physically wrong with one of the Pi boards, I tried swapping the locations of SD cards between machines. No luck there either. The wifi dongle always works with the regular Raspbian installation, but not RetroPie.

One last thing I've noticed - I read (somewhere along the way in a forum thread) that the blinking blue light on the wifi dongle indicates that it's receiving power. With the regular Raspbian SD card, it blinks consistently at a pretty constant rate. With the RetroPie SD card (with or without the powered hub), it blinks intermittently, sometimes pausing for a couple seconds. This occurs as soon as I boot up, before I try anything with wpa_gui. So...is there something about RetroPie that just screws up USB wifi connections? I spent a lot of time googling this, and found plenty of troubleshooting threads about wifi in general, but nothing this specific about RetroPie.

Any help would be greatly appreciated...I'm a complete Linux amateur, so if there's any information missing from this description that would be helpful for troubleshooting, just let me know what it is (and exactly what to type at the command line to get it) and I'll post it. Thanks!

bfinio
Posts: 38
Joined: Mon Oct 14, 2013 8:53 pm

Re: WiFi adapter working in regular Raspbian but not RetroPi

Tue Jan 28, 2014 4:39 pm

Quick update...the lsusb command does show that the Pi recognizes the wifi adapter:

pi@raspberrypi ~ $ lsusb

Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 0583:2060 Padix Co., Ltd (Rockfire)
Bus 001 Device 008: ID 0583:2060 Padix Co., Ltd (Rockfire)

bfinio
Posts: 38
Joined: Mon Oct 14, 2013 8:53 pm

Re: WiFi adapter working in regular Raspbian but not RetroPi

Wed Jan 29, 2014 4:12 pm

Answering my own question just in case anyone stumbles across this in the future: I was able to get WiFi working by starting over with a clean slate:
  • Re-flash the SD card
  • On first RetroPie bootup, when it brings you to the Player 1 button mapping screen, press F4 to exit RetroPie and go back to the command prompt.
  • Type startx to enter the normal desktop environment.
  • Use wpa_gui to set up wifi like you normally would. I didn't have any issues recognizing or connecting to the network this time.
  • Open a terminal and type emultationstation to re-start RetroPie. It should go back to the controller mapping screen and you can proceed as usual.
So, I'm not sure what happened...maybe some combination of setting up the USB controllers first along with having everything plugged into a single powered USB hub irrevocably screwed up communication with the USB wifi dongle? To be safe, on the second time around, I plugged the wifi dongle directly into one of the Pi's USB ports, and everything else into the hub. So, technically, I'm not sure if this solution (starting over and setting up WiFi before mapping the controllers) would also work if I still had everything plugged into the hub - but at this point I don't feel like trying.

Return to “Troubleshooting”