Scottbg1
Posts: 4
Joined: Mon Jul 10, 2017 5:20 pm

Re: RPi Cam Web Interface

Tue Jul 09, 2019 2:57 am

Having read that RPi Cam Web Interface was now working on Buster, I opted to do a fresh install of Buster and re-install the web interface.
I did the usual apt-get update and dist-upgrade before attempting the install.
Once I run the Web Interface installer, I get these messages after collecting the install packages and the installer stops.

Code: Select all

After this operation, 513 MB of additional disk space will be used.
Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpq5 armhf 11.3-1
  404  Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/p/postgresql-11/libpq5_11.3-1_armhf.deb  404  Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Are these repos just down temporarily, or is there an error in the install script?

Scottbg1
Posts: 4
Joined: Mon Jul 10, 2017 5:20 pm

Re: RPi Cam Web Interface

Tue Jul 09, 2019 1:12 pm

I discovered the problem was because since Buster's release it has been marked as stable, but apparently the source list needed to be tweaked.

I fixed it by running:

Code: Select all

sudo apt update --allow-releaseinfo-change
I hope this helps someone.

Manisch
Posts: 4
Joined: Sun May 12, 2019 1:34 pm

Re: RPi Cam Web Interface

Tue Jul 09, 2019 1:48 pm

ras07 wrote:
Mon Jul 08, 2019 3:05 pm
Manisch wrote:
Mon Jul 08, 2019 11:54 am
Manisch wrote:
Tue Jul 02, 2019 8:53 am
I'm still having the issue that the Camera is rebooting quite often. I would say...once every 10 minutes? Sometimes more, sometimes less...
Isn't there anyone who could help? :(

I don't want to sell this stuff again, because my project doesn't work...
Can you give some more information? What do you mean exactly by "the camera is rebooting" - the Pi itself reboots? What Pi version, OS version, etc.
Hmm, I'm not sure, wheater or not it's just the camera or the whole Pi that's rebooting. Is there some sort of log that's writing down such events?

I'm using:
Raspberry Pi Zero WH
Raspbian Stretch Lite. latest version
Joy-it IR-Pro 5MP IR CUT Camera

itsmedoofer
Posts: 335
Joined: Wed Sep 25, 2013 8:43 am

Re: RPi Cam Web Interface

Tue Jul 09, 2019 2:54 pm

wpballa1 wrote:
Sun Jul 07, 2019 12:37 am
Bob,
Now that Buster is out I'm having problems updating a Stretch installation. update.sh seems to work fine, but after I accept all the settings I get the following messages
E: Unable to locate package php7
E: Unable to locate package php7-cli
E: Unable to locate package libapache2-mod-php7
And the update to 6.5.1 process dies. I must reboot to get the camera going again, working through the interface it won't let me restart things. All of this is after a update/upgrade within Stretch. I can't tell whose problem this is.
Bill

Let me be a bit more clear. I have no intention of upgrading these Raspberry Pis to Buster as they are 3000 miles away and I can't easily get my hands on them. So, I guess I will leave the one at 6.4.50, but is there a way I could revert the 6.5.1 back to 6.4.50?
Have you tried entering 7.0 in the PHP field of the installer, when it asks for the port and so on, I think the issue could be you entered 7 ? Guessing here, but I think the script takes the exact value you enter and appends it to the package name, and the earlier packages are 7.0.

Worth a pop, save a bit of gas driving 6K miles :)

wpballa1
Posts: 49
Joined: Sat Jun 27, 2015 12:49 am

Re: RPi Cam Web Interface

Tue Jul 09, 2019 11:43 pm

Thanks, entering 7.0 in the php section did the trick, and thanks Bob for making a note of that in the installer.

ras07
Posts: 34
Joined: Tue May 22, 2018 4:04 am

Re: RPi Cam Web Interface

Wed Jul 10, 2019 1:30 am

Manisch wrote:
Tue Jul 09, 2019 1:48 pm
Hmm, I'm not sure, wheater or not it's just the camera or the whole Pi that's rebooting. Is there some sort of log that's writing down such events?
Well, there are lots of logs, but without knowing more about the symptoms, it's hard to know where to point you.

/var/log has most of the system logs. The syslog, kern.log, and messages files in the /var/log directory may have important info if the Pi is crashing. The Linux command dmesg may also give you useful info.

The Linux command uptime will tell you when the system was last rebooted, which may help you figure out what exactly is crashing.

If it's directly related to the camera, scheduleLog.txt in the /var/www/html (or wherever you have installed RPiCWI) may contain useful info.

One important thing to note - the Pi doesn't have a real-time clock, which means that immediately after booting, the time will be off until the system can synchronize the time from the internet. This can lead you astray when using log files for debugging purposes - if you see a big time jump, you might assume that's when the Pi rebooted. In reality that's when the time was synchronized. If your Pi crashes at 10:00 and you reboot it at 11:00, the Pi is still going to think it's 10:00 for most of the boot process. So if you're looking for the cause of a crash, it may not be whatever happened right before the time jump.

Can you SSH into the Pi (or access the terminal with a screen, keyboard and mouse) after it has "crashed"?

ras

CharlyDelta
Posts: 119
Joined: Thu Jul 18, 2013 4:04 am
Location: Montreal

Re: RPi Cam Web Interface ANNOTATE 3 SOLVED

Thu Jul 11, 2019 6:03 pm

After countless tests, I was finally able to print the temperature from an 18B20 on the monitor screen, with ANNOTATE function. But, the device id, 28-xxxxxxxxxxxxx also appears. How could it be possible to get only the temperature displayed?

Here is the code I'm trying now:

Code: Select all

#!/usr/bin/env python

import glob
import time

# DS18B20.py
# 2016-04-25
# Public Domain

# Typical reading
# 73 01 4b 46 7f ff 0d 10 41 : crc=41 YES
# 73 01 4b 46 7f ff 0d 10 41 t=23187

while True:

   for sensor in glob.glob("/sys/bus/w1/devices/28-00*/w1_slave"):
      id = sensor.split("/")[5]

      try:
         f = open(sensor, "r")
         data = f.read()
         f.close()
         if "YES" in data:
            (discard, sep, reading) = data.partition(' t=')
            t = float(reading) / 1000.0
            print("{} {:.1f}".format(id, t))
            annotate = open("/dev/shm/mjpeg/user_annotate.txt", 'w')
            annotate.write('{} {:.1f}' .format(id, t))
            annotate.close()
         else:
            print("999.9")

      except:
         pass

   time.sleep(3.0)
Thanks for your help

I finaly found the solution:

annotate.write('"{:.1f}"'.format ( t))

huresaich
Posts: 1
Joined: Fri Jul 12, 2019 10:33 am

Re: RPi Cam Web Interface

Fri Jul 12, 2019 10:45 am

I have a working installation and want to setup user access. During the install script I entered a username + password. However when I open the cam URL I can instantly access it. I assumed there would be some kind of login prompt, but the page behaves exactly the same as a previous install where I didn't specify a user. Now I am confused about how this is supposed to work. Can anybody tell me what I have to do to enable full access for one "admin" user and another user with restricted access in more detail?

User avatar
Mettauk
Posts: 232
Joined: Mon Dec 10, 2012 12:40 pm
Location: Zarg

Re: RPi Cam Web Interface

Tue Jul 16, 2019 12:52 pm

I've managed to get userbuttons working to switch GPIO to high/Low which is great news for all sorts of projects and can now switch the IR cut filter using the buttons, but...

I want to automate the IR cut filter on my camera for dawn and dusk and am bewildered by the Schedule Settings, totally bewildered.

I changed lattitude for RPi camera location but thats as far as I've got. Can someone please walk me through all or part of how?

To get userbuttons working I wrote a small python script and an sh script, I'm now guessing but maybe the On.sh and Off.sh scrips need to be integrated into the Schedule Settings, but how?

One of scripts

Code: Select all

#!/usr/bin/python
#IR cut filter switch OFF
import RPi.GPIO as GPIO
import time
GPIO.setmode(GPIO.BCM)
GPIO.setwarnings(False)
GPIO.setup(23,GPIO.OUT)
#print "IR cut on"
#GPIO.output(23,GPIO.HIGH)
time.sleep(0.3)
#print "IR cut off"
GPIO.output(23,GPIO.LOW)
The Macro

Code: Select all

#!/usr/bin/env bash
#echo "This is the bash script" &&
/usr/bin/python /home/pi/ir_cut_OFF.py
#echo "OFF"
As humans we have been the same for a very very long time, technology changes how we do... not who we are as people.

RaspiChase
Posts: 1
Joined: Fri Jul 19, 2019 12:12 pm

Re: RPi Cam Web Interface

Fri Jul 19, 2019 12:17 pm

@silvanmelchior - Firstly I would like to thank you for an amazing piece of software! I've been using RPi Cam Web Interface for years on numerous Pi's and absolutely love it!

RPi 3
RPi Camera V2 (8mp Sony)

Recently I've run into a problem where raspimjpeg is hanging/freezing after a short amount of time with 100% CPU usage on two processes for raspimjpeg. The image then freezes at the last "good" frame. Rebooting the Pi fixes the issues briefly but it typically happens again within minutes. I've updated everything with no luck. If I manually kill the raspimjpeg processes and use raspistill it works fine, so I don't believe it's a hardware issues. I've fully removed RPi Cam Web Interface and reinstalled with the latest version, unfortunately that did not resolve the issue either.

Before I attempt a full fresh image/reinstall I wanted to check and see if you or anyone else here have any suggestions.

Thanks again for great software and any help would be greatly appreciated!

Return to “Camera board”