Root file system insufficient free space, wont boot into GUI

4 posts
by Fabian_Debian » Fri Dec 13, 2013 2:00 am
I've googled quite a bit for this one... at first I thought it could be solved by "allocating" more space to root file system by boot into NOOBS setup screen, but it turned out I had given all my 6G available space to raspbian ALREADY WHEN SETTING RASPBIAN UP FOR THE FIRST TIME.

Now I suppose I need to flush some sort of cache? Because I must confess I had been using transmission for quite a deal... and I must've shutdown raspberry without quitting transmission first. So I suppose certain coder messed up the whole deal: instead of just using raspberry's RAM as cache for downloaded P2P data, it must've used up all the space on my SD card too, as file cache, you know, just like windows' virtual memory.

<You don't have to read this paragraph if you don't have much time at hand> So when I quit without closing down transmission first, certain procedure to flush the file cache on my SD card must had been skipped, and when next time I boot, root can't allocate enough space for system use, hence not entering the GUI. Of course, I could be entirely wrong.

So, here are the questions:
What do I do? A reinstall can solve the problem for sure, but I would lost all my downloading progress in transmission, I would have to hash check the heck out of my data, huge house of pain.

Since I still can enter the console-command mode of raspbian just fine, how do I manually enter the GUI? God it's like MS-DOS windows 95 all over again.

Is there any other smarter way to do this? Getting into GUI and continue using my transmission?
Posts: 9
Joined: Thu Dec 12, 2013 3:02 pm
by Fabian_Debian » Fri Dec 13, 2013 2:03 am
Oh silly me, I just entered startx, the screen went total blank. Where did I get this fancy idea of manually booting into GUI would work while the system had failed in the first place?
Posts: 9
Joined: Thu Dec 12, 2013 3:02 pm
by Fabian_Debian » Fri Dec 13, 2013 2:09 am
I hope I'm not so potty but I just df -h 'ed. This is what I found:
filesystem size used avail use%
rootfs 6.0 5.7 0.0 100%

What's going on here? What could possibly eat up all the space? And how do I solve this? How do I free up some space?
Posts: 9
Joined: Thu Dec 12, 2013 3:02 pm
by Fabian_Debian » Fri Dec 13, 2013 2:45 am
Problem solved guys, I mis-placed some file onto the desktop (a 3G+ file) so there went all the free spaces...

Now I removed that file and everything works fine... for now.
Posts: 9
Joined: Thu Dec 12, 2013 3:02 pm