mcfleeg
Posts: 8
Joined: Fri Oct 04, 2013 5:11 pm

How to install latest version of mpd?

Tue Nov 19, 2013 9:19 pm

How do I install the latest version of mpd on Raspbian? Its currently running version 0.16 and I really need the latest version 0.18.

It doesn't seem to update when doing apt-get update or upgrade....

Any help is appreciated.

elatllat
Posts: 1337
Joined: Sat Dec 17, 2011 5:05 pm

Re: How to install latest version of mpd?

Wed Nov 20, 2013 2:14 pm

something like

Code: Select all

apt-get remove mpd;
git clone git://git.musicpd.org/master/mpd.git
cd mpd
./configure
make
make install
(untested)
SBC with 32GB RAM: https://hardkernel.com

FAQ : https://raspberrypi.stackexchange.com

Unanswered: https://www.raspberrypi.org/forums/search.php?search_id=unanswered

mcfleeg
Posts: 8
Joined: Fri Oct 04, 2013 5:11 pm

Re: How to install latest version of mpd?

Wed Nov 20, 2013 3:35 pm

Thanks - I should have said that I did try building the latest mpd, but ./configure barks about needing a version of glib-2.xx that isn't installed.

Guess I'm also wondering how long it takes updated software/packages like mpd to make their way into the raspbian repositories. Maybe its when things move beyond "wheezy"?

Thanks again!
-Lee

elatllat
Posts: 1337
Joined: Sat Dec 17, 2011 5:05 pm

Re: How to install latest version of mpd?

Wed Nov 20, 2013 4:06 pm

SBC with 32GB RAM: https://hardkernel.com

FAQ : https://raspberrypi.stackexchange.com

Unanswered: https://www.raspberrypi.org/forums/search.php?search_id=unanswered

pharaoh35
Posts: 4
Joined: Thu Jan 08, 2015 10:58 pm

Re: How to install latest version of mpd?

Sat Feb 07, 2015 3:35 pm

I've just updated to mpd 0.19 version and these libs you'll need for compiling

sudo apt-get install libboost1.46-all-dev
sudo apt-get install libglib2.0-dev

Return to “Raspberry Pi OS”