silverdragon
Posts: 2
Joined: Sun May 01, 2016 1:09 am

Re: STICKY: Setting up HDMI output when video output is wrong.

Sat Aug 04, 2018 5:23 am

Hi, well I’m wondering if you actually need to power. On/off from the wall ie removing re-powering power from unit, this will master reset things then it maybe detected and remember? Anyhow good luck.

ibeeby
Posts: 7
Joined: Mon Jul 02, 2012 7:04 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Tue Aug 07, 2018 9:26 pm

Any ideas how I address a 1280x854 display? I have an ex-Apple PowerBook Titanium display panel with a VGA adapter being driven through an HDMI to VGA adapter as a display but the RPi doesn't really drive it properly - there is some munging of the characters and of course the resolution is wrong in either 1280x800 or 1280x900 settings.

Grateful for any thoughts.

Ian

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 4917
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: STICKY: Setting up HDMI output when video output is wrong.

Wed Aug 08, 2018 8:19 pm

ibeeby wrote:
Tue Aug 07, 2018 9:26 pm
Any ideas how I address a 1280x854 display? I have an ex-Apple PowerBook Titanium display panel with a VGA adapter being driven through an HDMI to VGA adapter as a display but the RPi doesn't really drive it properly - there is some munging of the characters and of course the resolution is wrong in either 1280x800 or 1280x900 settings.

Grateful for any thoughts.

Ian
Since you're using a HDMI-to-VGA adapter:
1) What model type (link or pics. perhaps)**
2) What do these tvservice commands report**** :

Code: Select all

tvservice -n
tvservice -m DMT
tvservice -m CEA
tvservice -s
Trev.
** FWIW, these are those I've used:
http://www.cpmspectrepi.uk/raspberry_pi ... erter.html
http://www.cpmspectrepi.uk/raspberry_pi ... rter2.html
http://www.cpmspectrepi.uk/raspberry_pi ... erter.html
http://www.cpmspectrepi.uk/raspberry_pi ... Audio.html
(the latter two for P0's) - is yours similar?
**** More info./examples here: http://www.cpmspectrepi.uk/raspberry_pi ... tings.html
Still running Raspbian Jessie on some older Pi's (an A, B1, B2, B+, P2B, 3xP0, P0W) but Stretch on my 2xP3A+, P3B+, P3B, B+, A+ and a B2. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

aBUGSworstnightmare
Posts: 1285
Joined: Tue Jun 30, 2015 1:35 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Thu Aug 09, 2018 9:51 am

ibeeby wrote:
Tue Aug 07, 2018 9:26 pm
Any ideas how I address a 1280x854 display? I have an ex-Apple PowerBook Titanium display panel with a VGA adapter being driven through an HDMI to VGA adapter as a display but the RPi doesn't really drive it properly - there is some munging of the characters and of course the resolution is wrong in either 1280x800 or 1280x900 settings.

Grateful for any thoughts.

Ian
Do you have access to the data sheet of your display?
If yes, you should configure Raspbian to ignore EDID data (which is coming from your adapter) and use a custom mode with correct HDMI timing to drive it.

Code: Select all

hdmi_ignore_edid=0xa5000080
This let's the Pi ignore the EDID data.

Have a look at this to get details on custom HDMI mode
https://github.com/raspberrypi/document ... t/video.md

zervanko
Posts: 14
Joined: Sat Jun 23, 2018 6:36 pm

Why option avoid_edid_fuzzy_match=1 not working?

Sun Sep 30, 2018 7:43 am

I set avoid_edid_fuzzy_match=1 to /boot/config.txt But my Raspberry still select lower resolution, because it has 162mhz (due to edidparser output)

User avatar
Yanazake
Posts: 31
Joined: Wed Dec 12, 2018 10:15 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Fri Feb 01, 2019 6:27 pm

Ok, i believe posting a question here would be better than a new post for this subject.

So, my pi and its cables are working fine, but for some reason I can't make it output to my Home Theater. I kinda wanted to take advantage of the sound system since it's HDMI anyway and some games/videos support it. Basically, it works on my tv, but I get a blank screen on the HT.

DirkS
Posts: 9807
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: STICKY: Setting up HDMI output when video output is wrong.

Fri Feb 01, 2019 6:32 pm

Yanazake wrote:
Fri Feb 01, 2019 6:27 pm
Ok, i believe posting a question here would be better than a new post for this subject.
No, it isn't. A new topic with a good, descriptive title will attract more attention then another addition on page 22 of an existing one...
And apparently the top post of this topic did not help you unless you did not try that.

nospam2k
Posts: 2
Joined: Fri Feb 01, 2019 7:11 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Mon Feb 04, 2019 8:42 pm

LG Flatron L194WT-SF. The output of tvservcie -s is correct (47) for the monitor per specs:

1440 x 900 h-freq: 55.935 v-freq 60

But on the console (no gui) there are vertical black lines every other column. It will work if I use 1024x768 but I'd like to use the full resolution.

Also, I don't know if this figures in but the montor is using a DVI-HDMI cable as there is no HDMI port.

Thanks.

egoinbloom
Posts: 2
Joined: Sat Mar 23, 2019 4:57 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Sun Mar 24, 2019 10:20 am

Hi,

I can't seem to get the right output. The screen is still blurry.

My edid looks like this:

Code: Select all

[email protected]:~ $ tvservice -d edid
Written 256 bytes to edid
[email protected]:~ $ edidparser edid
Enabling fuzzy format match...
Parsing edid...
HDMI:EDID version 1.3, 1 extensions, unknown aspect ratio
HDMI:EDID features - videodef 0x80 !standby !suspend !active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF
HDMI:EDID found monitor range descriptor tag 0xfd
HDMI:EDID monitor range offsets: V min=0, V max=0, H min=0, H max=0
HDMI:EDID monitor range: vertical is 50-76 Hz, horizontal is 30-80 kHz, max pixel clock is 160 MHz
HDMI:EDID monitor range does not support GTF
HDMI:EDID found monitor name descriptor tag 0xfc
HDMI:EDID monitor name is HDTV
HDMI:EDID found preferred DMT detail timing format: 1440x900p @ 60 Hz (47)
HDMI:EDID found DMT detail timing format: 1360x768p @ 60 Hz (39)
HDMI:EDID established timing I/II bytes are A3 08 00
HDMI:EDID found DMT format: code 4, 640x480p @ 60 Hz in established timing I/II
HDMI:EDID found DMT format: code 8, 800x600p @ 56 Hz in established timing I/II
HDMI:EDID found DMT format: code 9, 800x600p @ 60 Hz in established timing I/II
HDMI:EDID found DMT format: code 16, 1024x768p @ 60 Hz in established timing I/II
HDMI:EDID standard timings block x 8: 0x9500 0101 8100 8140 81C0 0101 0101 0101 
HDMI:EDID found DMT format: code 47, 1440x900p @ 60 Hz (16:10) in standard timing 0
HDMI:EDID found DMT format: code 28, 1280x800p @ 60 Hz (16:10) in standard timing 2
HDMI:EDID found DMT format: code 32, 1280x960p @ 60 Hz (4:3) in standard timing 3
HDMI:EDID found DMT format: code 85, 1280x720p @ 60 Hz (16:9) in standard timing 4
HDMI:EDID parsing v3 CEA extension 0
HDMI:EDID monitor support - underscan IT formats:no, basic audio:yes, yuv444:yes, yuv422:yes, #native DTD:4
HDMI:EDID found CEA detail timing format: 1280x720p @ 50 Hz (19)
HDMI:EDID found CEA detail timing format: 1920x1080i @ 50 Hz (20)
HDMI:EDID found CEA detail timing format: 720x480p @ 60 Hz (2)
HDMI:EDID found CEA detail timing format: 720x576p @ 50 Hz (17)
HDMI:EDID found CEA format: code 16, 1920x1080p @ 60Hz (native)
HDMI:EDID found CEA format: code 5, 1920x1080i @ 60Hz 
HDMI:EDID found CEA format: code 4, 1280x720p @ 60Hz 
HDMI:EDID found CEA format: code 3, 720x480p @ 60Hz 
HDMI:EDID found CEA format: code 7, 1440x480i @ 60Hz 
HDMI:EDID found CEA format: code 2, 720x480p @ 60Hz 
HDMI:EDID found CEA format: code 6, 1440x480i @ 60Hz 
HDMI:EDID found CEA format: code 1, 640x480p @ 60Hz 
HDMI:EDID found CEA format: code 31, 1920x1080p @ 50Hz 
HDMI:EDID found CEA format: code 20, 1920x1080i @ 50Hz 
HDMI:EDID found CEA format: code 19, 1280x720p @ 50Hz 
HDMI:EDID found CEA format: code 18, 720x576p @ 50Hz 
HDMI:EDID found CEA format: code 22, 1440x576i @ 50Hz 
HDMI:EDID found CEA format: code 17, 720x576p @ 50Hz 
HDMI:EDID found CEA format: code 21, 1440x576i @ 50Hz 
HDMI:EDID found CEA format: code 32, 1920x1080p @ 24Hz 
HDMI:EDID found audio format 2 channels PCM, sample rate: 32|44|48 kHz, sample size: 16|20 bits
HDMI:EDID found HDMI VSDB length 6
HDMI:EDID HDMI VSDB has physical address 1.0.0.0
HDMI:EDID HDMI VSDB supports AI:no, dual link DVI:no
HDMI:EDID HDMI VSDB deep colour support - 48-bit:no 36-bit:no 30-bit:no DC_yuv444:no
HDMI:EDID HDMI VSDB has no latency information
HDMI:EDID filtering formats with pixel clock > 162 MHz or h. blanking > 1023
HDMI:EDID best score mode initialised to DMT (4) 640x480p @ 60 Hz with pixel clock 25 MHz (score 0)
HDMI:EDID best score mode is now CEA (1) 640x480p @ 60 Hz with pixel clock 25 MHz (score 43432)
HDMI:EDID best score mode is now CEA (2) 720x480p @ 60 Hz with pixel clock 27 MHz (score 3045736)
HDMI:EDID CEA mode (3) 720x480p @ 60 Hz with pixel clock 27 MHz has a score of 45736
HDMI:EDID CEA mode (4) 1280x720p @ 60 Hz with pixel clock 74 MHz has a score of 80296
HDMI:EDID DMT mode (4) 640x480p @ 60 Hz with pixel clock 25 MHz has a score of 36864
HDMI:EDID CEA mode (5) 1920x1080i @ 60 Hz with pixel clock 74 MHz has a score of 87208
HDMI:EDID CEA mode (6) 1440x480i @ 60 Hz with pixel clock 27 MHz has a score of 35368
HDMI:EDID CEA mode (7) 1440x480i @ 60 Hz with pixel clock 27 MHz has a score of 35368
HDMI:EDID DMT mode (8) 800x600p @ 56 Hz with pixel clock 36 MHz has a score of 53760
HDMI:EDID DMT mode (9) 800x600p @ 60 Hz with pixel clock 40 MHz has a score of 57600
HDMI:EDID CEA mode (16) 1920x1080p @ 60 Hz with pixel clock 148 MHz has a score of 211624
HDMI:EDID DMT mode (16) 1024x768p @ 60 Hz with pixel clock 65 MHz has a score of 94370
HDMI:EDID CEA mode (17) 720x576p @ 50 Hz with pixel clock 27 MHz has a score of 2545736
HDMI:EDID CEA mode (18) 720x576p @ 50 Hz with pixel clock 27 MHz has a score of 45736
HDMI:EDID best score mode is now CEA (19) 1280x720p @ 50 Hz with pixel clock 74 MHz (score 4071080)
HDMI:EDID CEA mode (20) 1920x1080i @ 50 Hz with pixel clock 74 MHz has a score of 3628680
HDMI:EDID CEA mode (21) 1440x576i @ 50 Hz with pixel clock 27 MHz has a score of 35368
HDMI:EDID CEA mode (22) 1440x576i @ 50 Hz with pixel clock 27 MHz has a score of 35368
HDMI:EDID DMT mode (28) 1280x800p @ 60 Hz with pixel clock 83 MHz has a score of 147880
HDMI:EDID CEA mode (31) 1920x1080p @ 50 Hz with pixel clock 148 MHz has a score of 128680
HDMI:EDID CEA mode (32) 1920x1080p @ 24 Hz with pixel clock 74 MHz has a score of 74766
HDMI:EDID DMT mode (32) 1280x960p @ 60 Hz with pixel clock 108 MHz has a score of 172456
HDMI:EDID best score mode is now DMT (39) 1360x768p @ 60 Hz with pixel clock 85 MHz (score 4625336)
HDMI:EDID best score mode is now DMT (47) 1440x900p @ 60 Hz with pixel clock 106 MHz (score 5258280)
HDMI:EDID DMT mode (85) 1280x720p @ 60 Hz with pixel clock 74 MHz has a score of 135592
HDMI:EDID preferred mode remained as DMT (47) 1440x900p @ 60 Hz with pixel clock 106 MHz
HDMI:EDID has HDMI support and audio support
edidparser exited with code 0
[email protected]:~ $ 

So I changed to:
hdmi_group=1
hdmi_mode=16

It is an old laptop screen that I hooked it up with.
The screen is this one: LP171WP4(TL)(B1)
Datasheet: http://www.panelook.com/LP171WP4-TLB1_L ... _5769.html

What am I doing wrong?

edit:
I change hdmi_mode to 47, also doesn't work.
Changed hdmi_group to 2. Same result.

entomophile
Posts: 1
Joined: Mon May 06, 2019 3:15 pm

Re: STICKY: Setting up HDMI output when video output is wrong.

Mon May 06, 2019 3:34 pm

I have a rpi 3B+ running retropie. Everything runs fine when connected to my HDTV through an HDMI cable with the default config file..

I want to run it on an older VGA monitor. It is an IBM 9417-AB1, 1280x1024, 60 Hz, 5:4 ratio. I have the rpi connected to the monitor with this HDMI to VGA cable https://www.amazon.com/gp/product/B074G ... UTF8&psc=1 When connected to this monitor, the screen goes black once every 4 to 5 seconds.

I have made the following changes to the config.txt file as per the sticky but the screen still flashes:
hdmi_group=2
hdmi_mode=35
hdmi_drive=2

Note: the screen does not flash during the retropie startup sequence or when in the configuration menus.

I have also tried increasing the hdmi_boost to 6, hdmi_force_hotplug=1, and setting framebuffer width and height to 1280x1024 with no luck. I have also tried the default config file on a newer monitor with the VGA adapter and it flashed as well.

Any ideas of where to go next?

Return to “Troubleshooting”