XBMCantgetenough
Posts: 31
Joined: Wed Jan 09, 2013 2:05 am

unable to disable dynamic clocking for gpu_freq

Thu Aug 15, 2013 11:57 am

By enabling force_turbo=1 the arm is able to disable the dynamic overclocking. The same isn't true for all the gpu_freq namely v3d/h264

I'm using XBMC (openelec) and from experiments I've learnt v3d_freq is to do with the 3d transitions on the GUI. I've set it past the default 250. when using the command vcgencmd measure_clock v3d
I get output 0 when in standby. It only increases when I do something to XBMC (moving around) but theres some delay to reach the desired freq and I get stuttering. Funnily enough the isp high even though I'm not using it.

My question is how can I get v3d to always be on my config setting of 360 (v3d_freq=350) so I get a more fluid experience (the way isp_freq=360 is all the time) and second question how do I set isp_freq=0 all the time. I've set that at the config.txt but it still never accepts my input.

Thankyou

XBMCantgetenough
Posts: 31
Joined: Wed Jan 09, 2013 2:05 am

Re: unable to disable dynamic clocking for gpu_freq

Fri Aug 16, 2013 12:58 pm

Bump, I don't think anyone else has mentioned this so I just want some clarification. Just like arm can the gpu_freq mainly the v3d always be set at a value other than 0 when not in use? XBMC does use the GPU for the GUI and so it has a big impact on visual performance. I've set mine at 360 and it only kicks in after I'm moving around and by then its to late and it stutters. whereas the isp (even though I set it @ 0) is always set at 360. I would love if I can reverse this. Please any Developers wish to shine some light over here?

Considering the Pi is used alot for XBMC. This can be a good boost. and I can confirm that v3d is used by the GUI because I use vgencmd to check while I'm moving around.

Thankyou

XBMCantgetenough
Posts: 31
Joined: Wed Jan 09, 2013 2:05 am

Re: unable to disable dynamic clocking for gpu_freq

Sat Aug 17, 2013 12:21 pm

maybe I'm not asking in the right place. I've measured v3d (gpu freq) when doing nothing on my xbmc os on the Pi. Its 0. I've done page up and page down and only until I do fast button presses it goes up to whatever I set the v3d_freq. therefore the v3d (gpu frequency) is actually used for the gui. Unlike the raspbian image (untill wayland is implanted). So my question is can the v3d frequency be somehow set at a constant frequency above zero all the time? because theirs a delay before it shoots up causing stutter. I ask this because another gpu_freq the isp is never zero (even though I explicity set isp_freq=0, yet it never accepts that) so can the behaviour of v3d and isp, swapped so XBMC is a more fluid and enjoyable experience. Since I'm assuming a vast majority of users are using the RPi for XBMC, this can be the next boost for (perceived) performance. Any Dev's listening? Maybe I can respectfully email Dom for an answer because I beilive this deserves at least a repsonse.

Thankyou

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 26847
Joined: Sat Jul 30, 2011 7:41 pm

Re: unable to disable dynamic clocking for gpu_freq

Sat Aug 17, 2013 1:34 pm

I wouldn't expect stutter as the v3d clock ramps up - it does it exceptionally quickly (or should do). Perhaps the stutter is caused by something else?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

XBMCantgetenough
Posts: 31
Joined: Wed Jan 09, 2013 2:05 am

Re: unable to disable dynamic clocking for gpu_freq

Sat Aug 17, 2013 3:17 pm

Hi jamesh thankyou for your input

I have very high stable overclock settings of

arm_freq=1130
core_freq=560
h264_freq=360
isp_freq=0
v3d_freq=360
avoid_pwm_pll=1
current_limit_override=0x5A000020
sdram_freq=700
over_voltage_sdram=8
over_voltage=8
gpu_mem_512=128
initial_turbo=60
init_uart_clock=4000000
init_emmc_clock=500000000
disable_pvt=1
force_turbo=1

I've done a new install to. So its nothing else. It doesn't really stutter, but Its not a smooth transition like missed frame rates. But if I constantly move page up down and up, its smooth 3d transitions meaning that the v3d isn't kicking in fast enough for the intial 3d transition but is fine after that. I can also say that I'm ssh into the Pi and then I move around the menu screen (page up page down) and I use vcgencmd measure_clock v3d and I can see that it doesn't do it straight away.

But I would love you to answer this question. Why is isp always not at zero and its at the value set at the other GPU (360) even though I ask for zero value. And is it actually possible to have v3d fixed at my value of 360 without dynamic behaviour? (similar to force_turbo=1 for arm). So swap behaviour of v3d and isp? (isp always = zero and v3d always equal say 360)

With the settings I'm using I have a fast XBMC system but I believe the v3d can really boost the performance.

Thankyou

Return to “Advanced users”