paulie
Posts: 264
Joined: Thu Jan 19, 2012 6:51 pm

I2ckiss : poll failed

Thu Jul 25, 2013 7:03 am

I have a TNC-Pi connected by i2c.
Tnc (modem) takes afsk ax25 tones & feeds them over gpio to RPi for display in Xastir.

Interfaces set up in xastir: gps (gpsd) on serial uart (works well).
I2c, using i2ckiss (flaky, hence this posting).

I2c enabled & not blacklisted & i2c-tools installed.
Bring up tnc link

Code: Select all

i2ckiss 1 16 symlink /dev/com1
I2c address already set earlier.
"packet received" appears in terminal window, & data passes to xastir.
After about 1 hr I get "i2c poll failed" & xastir I/face goes into error.
Have to reset tnc to get I/face back up.

Any idea why poll fails on i2c, & how do I stop it happening?
I2cdetect -Y shows tnc is there, have tried on early & late model B.

Update Jan 2014: did apt-get update & dist-upgrade, but still get errors. Would like this to run unattended for RAYNET user service RX only.

Could run cron script to reset tnc but Xastir iface has to be started manually.
Any i2c experts out there?
It has been my custom to use Xeyes

paulie
Posts: 264
Joined: Thu Jan 19, 2012 6:51 pm

Re: I2ckiss : poll failed

Fri Jan 10, 2014 1:29 pm

I discovered there's a new version of the i2ckiss software by John W2FS,
so will test & report back

https://dl.dropboxusercontent.com/u/31910649/i2ckiss
It has been my custom to use Xeyes

paulie
Posts: 264
Joined: Thu Jan 19, 2012 6:51 pm

Re: I2ckiss : poll failed

Wed Jan 15, 2014 9:29 pm

New version of i2ckiss script is much better, but not perfect.
It doesn't barf out at the first opportunity: I have got uptimes for the i2c interface
From between 1 hour & 24 hours, and can see errors posted to /var/log/syslog.
e.g. CRC Error 255/CRC Error 14/CRC Error 48/Frame too long.
Not sure which of these is the deal breaker.
Thanks go to John W2FS for the new version, (and of course, for the TNC-Pi !)
It has been my custom to use Xeyes

Return to “Interfacing (DSI, CSI, I2C, etc.)”