mecarter
Posts: 4
Joined: Sun Jan 22, 2012 5:43 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 10:06 am

Using the latest Debian6-19-04-2012 image, the System Preferences -> Display Settings are preset to 1344x804 and not detecting my ViewSonic VA1930WM native 1440x900 monitor configuration.  The previous Debian6-13-04-2012 image worked fine detecting the Resolution as 1440x900.  What has changed?  How do I fix this to set up 1440x900 resolution?  The monitor is connected via the DVI input.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5410
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 10:48 am

Run /opt/vc/bin/tvservice -d edid.dat
And post this file.

mecarter
Posts: 4
Joined: Sun Jan 22, 2012 5:43 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 11:34 am

How do I post a copy of the file?

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5410
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 11:44 am

All sorts of ways. Dropbox is generally useful for lots of thing. You can put a file in your public folder, and post a link to it.

Here is a referral link: http://db.tt/BaEuIbo where we both get an extra 250M storage. It is free.

rogerdean
Posts: 21
Joined: Tue Apr 17, 2012 7:40 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 11:55 am

Same story here - Samsung telly via HDMI. Here's edid.dat http://dl.dropbox.com/u/981187/edid.dat

Am having so much fun with this...

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5410
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 12:27 pm

@mecarter I think I misunderstood your original post. Reading again, I think the monitor is actually in 1440x900 mode, but you are unhappy the resolution of the framebuffer (and so X) has reduced. That sounds like it is due to overscan adjustment. We now default to not using the edge pixels, as many users complained their TV didn't show them (due to no way of disabling overscan).

Create a file config.txt on boot partition containing "disable_overscan=1".

You can do this in windows, or from Pi:

sudo sh -c "echo disable_overscan=1 >> /boot/config.txt"

should do it. Then reboot.

@rogerdean can you be more specfic. Do you have exactly @mecarter's problem or something different?

mecarter
Posts: 4
Joined: Sun Jan 22, 2012 5:43 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 1:58 pm

@dom Yes, that fixed it; thank you.

I too am having a lot fun.

clifmeister
Posts: 5
Joined: Thu Mar 29, 2012 1:34 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 3:35 pm

dom said:


Create a file config.txt on boot partition containing "disable_overscan=1".

You can do this in windows, or from Pi:

sudo sh -c "echo disable_overscan=1 >> /boot/config.txt"

should do it. Then reboot.


I tried this and get Permission denied.

rogerdean
Posts: 21
Joined: Tue Apr 17, 2012 7:40 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 3:40 pm

Thanks very much indeed dom, same problem, same solution, all well

Roger

itsonlyme
Posts: 129
Joined: Sun Feb 12, 2012 12:43 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 3:48 pm

Same problem here and now solved. Thanks

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5410
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: 1440x900 with Debian6-19-04-2012 broken

Sat Apr 21, 2012 3:52 pm

@clifmeister Really? You typed this in on Pi? What distribution are you using?

You could also do (on Pi) "sudo nano /boot/config.txt" and enter "disable_overscan=1"

Or just use Windows.

clifmeister
Posts: 5
Joined: Thu Mar 29, 2012 1:34 pm

Re: 1440x900 with Debian6-19-04-2012 broken

Fri Apr 27, 2012 3:33 pm

Using Debian6-19-04-2012, but it turns out my problem was with my keyboard. I am using a standard American Dell keyboard, and when I typed " i got @... Couldn't see it because of the overscan! I used nano and managed to get the overscan disabled. Now I have to figure out how to set the keyboard to US instead of UK!

z0mb13e
Posts: 14
Joined: Fri Sep 02, 2011 10:45 am

Re: 1440x900 with Debian6-19-04-2012 broken

Mon May 07, 2012 2:20 pm

I was having the same problem and not getting anywhere with the disable_overscan line in the config. Restarting X didn't have the desired effect. Seems you actually have reboot the Pi... kinda used to not rebooting Linux to fix problems so a reboot seemed overkill... so anyway a reboot fixed it.

(I was gonna post this from the Pi, but the comment field is too slow in Midori to type into).

Return to “Troubleshooting”