Posts: 4
Joined: Sat Jul 13, 2013 3:26 pm

2013-05-25-wheezy-raspian.img Dissapointment

Wed Jul 17, 2013 10:41 pm

Hi Folks

I have five pi's in service doing various tasks. This last weekend I discovered that the new pi's do not like the 2012-12-16 image that I have been happily using.

So I downloaded the newest image, and have to tell you that either I was spoiled in the past, or.... there is some patching ahead.

The chief issue for me is that instead of firing up the pi, headless, and then ssh'ing into it and getting on with using it, I wasted a half hour just getting it on the network etc.

I needed to manually add a few lines to /etc/network/interfaces to get the networking set up via dhcp:
auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

Then restart the networking:
/etc/init.d/networking restart
...and got the networking up.

Then I visited the raspi-config, and found that the option for turning on ssh on boot was producing an error, and so was each localization option.

I fixed this by:
sudo rm /etc/ssh/ssh_host*
sudo ssh-keygen -A
/etc/init.d/ssh start

I updated the os: apt-get update, tried an upgrade: apt-get upgrade and ran the: rpi-update command, liberally rebooting, with no changes to the functionality in the raspi-config utility.

So....I was used to the basic, default dhcp and ssh and the raspi ****just working****........am I dealing with a common issue with this release, or is my sd card beset with a poor image transfer?

I love the pi when I can get to use it without fuss.......

Posts: 3562
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: 2013-05-25-wheezy-raspian.img Dissapointment

Wed Jul 17, 2013 11:13 pm

Load SD card with 2013-05-25-wheezy-raspbian, plug it into the Pi, connect network cable to the Pi, power on Pi. Open Putty on Win7 laptop, enter hostname and Open. Log in to Pi.

No trouble at all. /etc/network/interfaces is default

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Posts: 4
Joined: Sat Jul 13, 2013 3:26 pm

Re: 2013-05-25-wheezy-raspian.img Dissapointment

Wed Jul 17, 2013 11:55 pm

Hi Mr Engman

As you have described is exactly how I have always experienced the wheezy os....it usually all works by default, no time wasted setting all of the basics up.

I'll write another sd card and see if that changes things, and if not will test a new image download. As I have done this many many times always with proper results, I do not think any of that would have caused these "non start" issues.

Thanks for the feedback, there may be hope yet for this version.

Posts: 4
Joined: Sat Jul 13, 2013 3:26 pm

Re: 2013-05-25-wheezy-raspian.img Dissapointment

Thu Jul 18, 2013 1:21 am


I wrote the same image to a different SD card (mac book via bash) same method as before except a 2 gig card vs 8 gig.

Everything worked as intended this time. It picked up an IP, allowed SSH from the get-go and the raspi-config is working.

So it seems as though a bad image write or a bad SD card can give you a working OS but with "issues" that should not be present.

Very pleased that the troubleshooting I had to do originally will not be needed with this and future implementations.

User avatar
Posts: 2156
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
Contact: Website

Re: 2013-05-25-wheezy-raspian.img Dissapointment

Thu Jul 18, 2013 6:08 am

Good to hear you solved it.
I had none of those issues with the 5/25/13 Raspbian wheezy image. I install it on one card and RSE2.4 (Raspbian Server Edition) on 2 others which is built from the same image. All worked just fine.
512MB version 2.0 as WordPress Server
Motorola Lapdock with Pi2B
Modded Rev 1.0 with pin headers at USB

(RS)Allied ships old stock to reward its Customers for long wait!

Return to “General discussion”

Who is online

Users browsing this forum: areslinux and 40 guests