knick007
Posts: 16
Joined: Tue Jan 22, 2013 7:41 am

Monitor not full screen

Sat Jun 15, 2013 7:39 am

Hi
I have a raspberry pi connected to a samsung 23" monitor via HDMI however the pi only fills some of the monitor and I'd rather it would fill the entire thing.(
photo 1.JPG
Pi Desktop
photo 1.JPG (27.9 KiB) Viewed 108799 times
) In contrast I my macbook pro attached to the monitor as well and it easily fills the screen.(
photo 2.JPG
Macbook Pro
photo 2.JPG (39.73 KiB) Viewed 108797 times
) I don't really expect the Pi to just detect the settings by itself but when I go to the display settings the resolution is 1824x924 with the only other option being auto. Does anyone have any ideas how I can fix this? not a big deal I can still see the monitor and everything, I'm just curious if it is possible to fix.

Edit* why the hell is the second photo upside-down? lol Sorry for any inconvenience this causes I have tried deleting and re-uploading and no change

User avatar
rpdom
Posts: 14758
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Monitor not full screen

Sat Jun 15, 2013 8:41 am

Look in your /boot/config.txt file for the disable_overscan setting. Set it to 1 and make sure there isn't a # on the front of the line.

michaeldye
Posts: 1
Joined: Mon Nov 04, 2013 8:30 pm

Re: Monitor not full screen

Mon Nov 04, 2013 8:41 pm

Hi all - just a note to anyone browsing this:

If you've used NOOBS then don't fall for the first disableoverscan in this config.txt file.

Look further down: there *may* be a whole section with overscan and borders; remark out the 4 border lines and alter the disableoverscan line... that should do it.

Ta
Michael Dye

RPi121
Posts: 2
Joined: Sat Nov 16, 2013 11:00 am

Re: Monitor not full screen

Sat Nov 16, 2013 11:04 am

You might want to google "overscan" and "underscan"
*EDIT* this looks good :) http://www.raspberrypi.org/phpBB3/viewt ... =28&t=7693

M3lchizedek
Posts: 1
Joined: Thu Jan 15, 2015 9:59 pm

Re: Monitor not full screen

Thu Jan 15, 2015 10:17 pm

like root open the file /boot/config.txt
Just verify:

Code: Select all

disable_overscan=1
must be uncommented and with the value 1

this others:

Code: Select all

#overscan_left=-20
#overscan_right=-20
#overscan_top=-20
#overscan_bottom=-20
must be commented

And finally you must verify that in the end of the file, the tool to install the S.O NOOBS had not put the same lines of configuration

Code: Select all

#NOOBS Auto-generated settings
overscan_left=24
overscan_right=24
overscan_top=16
overscan_bottom=16
disable_overscan=0
If NOOBS put this configuration lines in your file just set the correct value for

Code: Select all

disable_overscan=1
and comment the overscan_direction lines. Remember if the same configuration line repeats two or more times, the last is loaded by the operative system.

DON'T FORGET RESTART

Code: Select all

sudo reboot
I hope this can be useful to somebody.

Greetings.

fdufnews
Posts: 289
Joined: Fri Oct 07, 2011 5:37 pm

Re: Monitor not full screen

Fri Jan 16, 2015 11:58 am

when I go to the display settings the resolution is 1824x924
This makes me think your monitor is not correctly detected.
Perhaps you can look here http://www.raspberrypi.org/documentatio ... fig-txt.md
and force the HDMI_MODE

BMS Doug
Posts: 3824
Joined: Thu Mar 27, 2014 2:42 pm
Location: London, UK

Re: Monitor not full screen

Fri Jan 16, 2015 12:29 pm

fdufnews wrote:
when I go to the display settings the resolution is 1824x924
This makes me think your monitor is not correctly detected.
Perhaps you can look here http://www.raspberrypi.org/documentatio ... fig-txt.md
and force the HDMI_MODE
the post you are responding to was made in 2013, I expect it has been resolved by now.
Doug.
Building Management Systems Engineer.

Return to “General discussion”