mdasrafulislam
Posts: 6
Joined: Fri Mar 22, 2013 8:11 pm

How to disable monitor power saving option in Raspberry PI?

Thu May 16, 2013 6:11 am

I don't want that my monitor will go power saving option after sometime. I tried different option to stop power save option but none of them worked. I am using Raspberry wheezy soft float version.
Can anyone help me how I can configure this issue?

User avatar
RaTTuS
Posts: 10330
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: How to disable monitor power saving option in Raspberry

Thu May 16, 2013 6:53 am

what have you tried
editing /etc/kbd.config should be good enough unless you are running x
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
jojopi
Posts: 3078
Joined: Tue Oct 11, 2011 8:38 pm

Re: How to disable monitor power saving option in Raspberry

Thu May 16, 2013 7:02 am

I think you will find that the screen is just blanking and not going into power save, since the latter does not appear to be implemented on the Pi. In any case, power saving is never enabled until after the screen has blanked or the screensaver activated, so it is only the blanking or screensaver timeout that you need to change.

You have not said whether you are using the text console or the X Window System. For the kernel console, just set BLANK_TIME=0 in /etc/kbd/config.

For X you can either install and configure a screensaver; disable the default screensaver with xset; or disable the default screensaver by options on the X server command. See this thread for details: http://www.raspberrypi.org/phpBB3/viewt ... p?p=180028

chorlton2080
Posts: 124
Joined: Sun Dec 23, 2012 9:44 pm

Re: How to disable monitor power saving option in Raspberry

Mon Jul 15, 2013 8:40 pm

I had the same problem on Ubuntu. I couldn't find an adequate fix so I used Xdotool to send a benign keystroke every 5 minutes using cron.

Can't check at this moment whether Xdotool is available on Wheezy, but if so that will be a solution to both Console and X screen blanking and screensavers.

User avatar
jojopi
Posts: 3078
Joined: Tue Oct 11, 2011 8:38 pm

Re: How to disable monitor power saving option in Raspberry

Thu Jul 18, 2013 9:45 pm

chorlton2080 wrote:Can't check at this moment whether Xdotool is available on Wheezy, but if so that will be a solution to both Console and X screen blanking and screensavers.
xdotool obviously will only work in X, and not on console. Along similar lines and much more portably, you could build a robot to physically press your shift key every couple minutes.

Seriously though, it is better, and really not difficult, to disable screen blanking instead of fighting against it.

chorlton2080
Posts: 124
Joined: Sun Dec 23, 2012 9:44 pm

Re: How to disable monitor power saving option in Raspberry

Thu Jul 18, 2013 9:55 pm

Yes. That makes sense. The clue is in the name: Xdotool.

I think it worked for me because I SSHd into Ubuntu whilst the X Session was running, with its resultant grip on the power saving features. This is not how Raspberry Pi users normally access the console.

B.Jay
Posts: 28
Joined: Thu Jul 18, 2013 10:57 pm

Re: How to disable monitor power saving option in Raspberry

Thu Jul 18, 2013 11:05 pm

If you want to prevent the blanking of the console:

Code: Select all

sudo nano /etc/rc.local
ABOVE the "exit 0" line insert:

Code: Select all

setterm -blank 0 -powerdown 0 -powersave off
The file should look like this:

Code: Select all

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
fi

# Disable console blanking
setterm -blank 0 -powerdown 0 -powersave off

exit 0
Save the file.

Either reboot or issue the command right away on the command line (don't forget to prefix "sudo").

That's it - the console won't blank.

Works for me on the latest Raspbian 7 Hard Float as well on Minibian (created by some forum user).

User avatar
ds18s20
Posts: 81
Joined: Fri Dec 23, 2011 5:44 am
Location: San Francisco

Re: How to disable monitor power saving option in Raspberry

Sun Mar 02, 2014 7:21 pm

Ok I'm confused. Just for the console (exclude X from the discussion). Which one is it?

sudo nano /etc/rc.local or /etc/kbd.config

Was the previous suggestion to edit /etc/kbd.config a defective solution to the problem?

Thanks
~B

User avatar
RaTTuS
Posts: 10330
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: How to disable monitor power saving option in Raspberry

Mon Mar 03, 2014 9:29 am

ds18s20 wrote:Ok I'm confused. Just for the console (exclude X from the discussion). Which one is it?

sudo nano /etc/rc.local or /etc/kbd.config

Was the previous suggestion to edit /etc/kbd.config a defective solution to the problem?

Thanks
~B
if you edit
/etc/kdb/config
and change BLANK_TIME=30 to 0
it will stop blanking
if you edit
/etc/rc.local
and add
setterm -blank 0
you will have to same effect

in unix [and linux] there are many ways to skin a cat
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Return to “Advanced users”