joepshoulak
Posts: 4
Joined: Thu Apr 25, 2013 1:28 pm

GPIO setup correctly, no output

Mon Apr 29, 2013 6:54 pm

So I connected pin 17 (GPIO 11) to one terminal of a motor, and pin 6 (GND) to the other pin, and when I sent the command for output to be sent to that pin (True, 1, HIGH, whatever...), nothing happened. I was, however, able to drive the motor off pins 2 (5v) and 6 (GND) and pins 1 (3.3v) and 6 (GND), but not off the GPIO pin. I got no error, and I tried it using Python, Ruby, C++, and just straight up Bash commands. Nothing worked.

My wires are good, my breadboard is good, my code is good, my motor is good, what am I missing?

:?:

techpaul
Posts: 1514
Joined: Sat Jul 14, 2012 6:40 pm
Location: Reading, UK
Contact: Website

Re: GPIO setup correctly, no output

Mon Apr 29, 2013 6:59 pm

If you want to fry your Pi carry on.

The GPIO pin is a low power on / off switch, not a motor power supply.

You need to add proper motor control serach for motor controllers and other motor driving subjects in the search box or from places like google.

Your motor is wanting at least 100's mA and nasty back EMF when stopping, a GPIO output cannot supply more than about 16mA.
Just another techie on the net - For GPIO boards see http:///www.facebook.com/pcservicesreading
or http://www.pcserviceselectronics.co.uk/pi/

User avatar
rpdom
Posts: 11426
Joined: Sun May 06, 2012 5:17 am
Location: Essex, UK

Re: GPIO setup correctly, no output

Mon Apr 29, 2013 7:08 pm

joepshoulak wrote:So I connected pin 17 (GPIO 11)
I presume you mean pin 11 (GPIO 17)?

Even so, techpaul is right. You need a proper motor drive circuit, otherwise you may kill that GPIO pin by overcurrent.

joepshoulak
Posts: 4
Joined: Thu Apr 25, 2013 1:28 pm

Re: GPIO setup correctly, no output

Tue Apr 30, 2013 7:09 pm

Is it possible for a single pin to burn out, or will it burn out the entire chip?

techpaul
Posts: 1514
Joined: Sat Jul 14, 2012 6:40 pm
Location: Reading, UK
Contact: Website

Re: GPIO setup correctly, no output

Tue Apr 30, 2013 7:12 pm

Yes you could blow one pin depends on how it failed.
Just another techie on the net - For GPIO boards see http:///www.facebook.com/pcservicesreading
or http://www.pcserviceselectronics.co.uk/pi/

scotty101
Posts: 2246
Joined: Fri Jun 08, 2012 6:03 pm

Re: GPIO setup correctly, no output

Tue Apr 30, 2013 7:19 pm

May I suggest that you do some research before you connect anything up to your raspberry pi.

I have found that the Adafruit tutorials are excellent and suitable for beginners

http://learn.adafruit.com/category/raspberry-pi
Electronic and Computer Engineer
Pi Interests: Home Automation, IOT, Python and Tkinter

Return to “Beginners”

Who is online

Users browsing this forum: asandford and 39 guests