[SOLVED] Bluetooth... Big problems!


2 posts
by killkrt » Sun Mar 31, 2013 3:14 pm
Hi!

I bought a Bluetooth adapter (http://www.speedlink.com/?p=2&cat=271&pid=20182&paus=1) and I got some problems with Raspbian.

This is my lsusb output:
Code: Select all
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 07d1:3303 D-Link System DWA-131 802.11n Wireless N Nano Adapter(rev.A1) [Realtek RTL8192SU]
Bus 001 Device 008: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 007: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser

This is dmesg output (when I tried to replug the adapter):
Code: Select all
[  213.650320] usb 1-1.2.2: new full-speed USB device number 8 using dwc_otg
[  213.930794] usb 1-1.2.2: New USB device found, idVendor=0a12, idProduct=0001
[  213.930825] usb 1-1.2.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  213.930842] usb 1-1.2.2: Product: CSR8510 Nanosira M2272
[  216.069989] Bluetooth: hci0 command 0x1009 tx timeout
[  218.070060] Bluetooth: hci0 command 0x0c14 tx timeout
[  220.070159] Bluetooth: hci0 command 0x0c25 tx timeout
[  222.070233] Bluetooth: hci0 command 0x0c05 tx timeout

This is my lsmod output (I've already blacklisted module bnep following instructions from another thread):
Code: Select all
Module                  Size  Used by
...
bluetooth             193568  13 btusb,rfcomm
...

This is the hciconfig -a output:
Code: Select all
hci0:   Type: BR/EDR  Bus: USB
   BD Address: 00:00:00:00:00:00  ACL MTU: 310:10  SCO MTU: 64:8
   DOWN
   RX bytes:334 acl:0 sco:0 events:10 errors:0
   TX bytes:39 acl:0 sco:0 commands:12 errors:0

But if I try to execute the comand hciconfig scan I get a:
Code: Select all
Device is not available: No such device

Moreover if I try "sudo hciconfig hci0 up":
Code: Select all
Can't init device hci0: Connection timed out (110)

I've already tried to restart the bluetooth service with
Code: Select all
/etc/init.d/bluetooth restart

But I still get these errors! :cry:

Could you please help me?

Thanks.
Last edited by killkrt on Mon Apr 01, 2013 12:54 pm, edited 1 time in total.
Posts: 6
Joined: Fri Mar 29, 2013 12:59 pm
by killkrt » Mon Apr 01, 2013 12:54 pm
Fixed upgrading the firmware (using this https://github.com/Hexxeh/rpi-update)! :D
Posts: 6
Joined: Fri Mar 29, 2013 12:59 pm