I got locked out of my raspberry pi

5 posts
by lionlion44 » Thu Jan 24, 2013 9:55 am
I am new to this so i didn't really know what was going on but i attempted to make a password in the config menu. When asked to input a password i could not type in anything i pressed enter, it asked me to re-type it and i again pressed enter, it then showed an error message saying it could it failed to set a password or somthing. i press finish on the config and reboot the system. after loading it asks me to enter a login and password (the password of which i still can not type). I've tried a lot of things like rebooting and entering pi as the login but nothing works. Is there a way of getting around this or will i have to re-install the operating system. I have never tried to do anything like Linux so please don't assume I'm just an idiot.
Posts: 1
Joined: Thu Jan 24, 2013 9:40 am
by ghans » Thu Jan 24, 2013 10:04 am
You don't see any stars or dots when you type in your password.
Just type in blindly (the default password is on the downloads
page if you forgot it). Note the UK keyboard layout , which
can be changed through the menu which pops up if you
log in sucessfully for the first time.

• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org
Posts: 7206
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany
by noscope900 » Thu Jan 24, 2013 10:05 am
Reflash the sd card, its really not hard.

Get the .img for your preferred os from the downloads page, and use win32diskimager (also linked over there) to put it onto the sd card. I leave mine as it is, I don't expect anyone trying to get on to my pi.
Posts: 73
Joined: Wed Oct 24, 2012 5:21 pm
by RobHenry » Thu Jan 24, 2013 6:54 pm
Not sure why you think you couldn't enter a password - just type it in blind (and carefully) because the cursor does not move while you type the password.
Posts: 452
Joined: Fri Sep 21, 2012 9:04 pm
Location: UK
by drgeoff » Thu Jan 24, 2013 8:43 pm
As ghans said, retry with the default password. If you got an error message that the password could not be changed, it will still be the default. Note that username and password are case sensitive.

(The chances are 100 to 1 that you got the error message when trying to change the password because the first and second times did not match exactly.)
Posts: 6770
Joined: Wed Jan 25, 2012 6:39 pm