Mouse problem

5 posts
by iFrankDaPug » Mon Jan 21, 2013 1:18 am
Hello, I recently received a Raspberry Pi as a Christmas present. I have never used one before, nor have I used Linux. So far, I am getting nowhere. My keyboard and mouse were not working. I was given the advice to purchase a powered USB hub. My keyboard works but my mouse does not. I have tried three different mice. They are all getting power and all work on my laptop, but none seem to work on my pi. Can anybody walk me through and help me diagnose the problem.
Posts: 3
Joined: Mon Jan 21, 2013 1:15 am
by SimonSmall » Mon Jan 21, 2013 7:29 am
It is hard to tell how far you have got - what distribution is on your SD card?

When you say your mouse does not work, are you using the graphical interface or the text interface. If all you have on your screen is text, the mouse will not do anything. Type "startx" to get the graphical screen, which will look like the usual Windows / Mac screen. Your mouse should work on this

Please post back more details
Posts: 220
Joined: Tue Oct 09, 2012 8:13 pm
by iFrankDaPug » Mon Jan 21, 2013 3:08 pm
I bought my SD card with my Raspberry pi. It is currently running Soft-float Debian “wheezy”. I have gotten the graphical interface up. I could also use ctrl alt delete to make sure that it was not frozen and it worked.
Posts: 3
Joined: Mon Jan 21, 2013 1:15 am
by Onlyname » Mon Jan 21, 2013 3:43 pm
Just out of curiosity, have you tried connecting the mouse directly to the USB and not to the HUB?
Also, what kind of power supply do you have? This could be a problem...
Posts: 11
Joined: Tue Jan 08, 2013 6:09 pm
by iFrankDaPug » Sun Feb 03, 2013 7:41 pm
I tried using a normal USB hub and a powered one. Neither of them have worked with five different mice. They light up to show that they have power, but to not move the cursor on the screen. I tried disconnecting everything but the powered USB hub and the keyboard works but the mouse does not.
Posts: 3
Joined: Mon Jan 21, 2013 1:15 am