Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

No overclock option in raspi-config

Sat Jan 12, 2013 6:04 am

When I go to raspi-config there is no overclock feature, or update. All I see is Info, Configure_keyboard, Change_Pass, Change_Locale, Change_Timezone, SSH, Boot_Behaviour.
Im not sure whats wrong. Its running off a 80GB external HDD, With Raspbian installed. 8GB PNY premium SD card.

Not sure how to replicate it? Just started it and there is options missing from the menu. It showed up on all the other SD cards I run. I haven't done anything different on how I installed it.

Thanks

BrickTopUK
Posts: 4
Joined: Fri Jan 11, 2013 5:42 pm

Re: No overclock option in raspi-config

Sat Jan 12, 2013 11:30 pm

Hey man, If you are still having this issue, I found that I didn't have the correct repositories listed in my /etc/apt/sources.list file. I added this to the file and then it updated fine!

deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free

Hope it works!

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sat Jan 12, 2013 11:43 pm

So where is the file in the site you gave?

drgeoff
Posts: 7317
Joined: Wed Jan 25, 2012 6:39 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 1:36 am

Yamahanytro wrote:So where is the file in the site you gave?
You add the two lines:

Code: Select all

deb http://archive.raspbian.org/raspbian wheezy main contrib non-free
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free
to the file /etc/apt/sources.list on your RPi.

User avatar
malakai
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am
Contact: Website

Re: No overclock option in raspi-config

Sun Jan 13, 2013 1:50 am

Where did the image come from was it pre-loaded?

Have you tried

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install raspi-config libraspberrypi*

reboot and see what is there.
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 1:52 am

I added those then rebooted and ran

Code: Select all

apt-get update && apt-get upgrade
This is what I got: http://gyazo.com/1ed70c6510a3726537758d22fccdb366

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 1:52 am

malakai wrote:Where did the image come from was it pre-loaded?

Have you tried

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install raspi-config libraspberrypi*

reboot and see what is there.
I installed raspbian with BerryBoot
I will try

Code: Select all

sudo apt-get install raspi-config libraspberrypi*
right now.

Edit: Just tried it. Said its the latest version.

User avatar
malakai
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am
Contact: Website

Re: No overclock option in raspi-config

Sun Jan 13, 2013 1:56 am

Berryboot won't have an overclock setting in raspi-config. I forget how to do it would have to read up on it. It boots differently than the main OS by itself so there is a way just not in raspi-config
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 2:02 am

malakai wrote:Berryboot won't have an overclock setting in raspi-config. I forget how to do it would have to read up on it. It boots differently than the main OS by itself so there is a way just not in raspi-config
The other SD cards I have that I installed using BerryBoot had the Raspi-Config in them, with the overclock feature.

User avatar
malakai
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am
Contact: Website

Re: No overclock option in raspi-config

Sun Jan 13, 2013 2:11 am

http://www.raspberrypi.org/phpBB3/viewt ... 59#p249559
Hi, I have installed raspbian and openelec with "berryboot-20121230" but when I type sudo rasp-config there's no option to overclock, raspi-update, etc...
Max the author wrote:
Firmware has to be updated through the Berryboot GUI, not using rpi-update.

If you know what you are doing, you can set overclock settings through the Berryboot GUI (advanced settings -> config.txt tab). I would not recommend anyone to overclock though.

No need to change memory split manually anymore, Long live CMA.
I would ping him in that thread or rename this if possible as it won't possibly hit his attention. But it looks like if it was there it isn't anymore.
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 2:18 am

Would this allow me to overclock without voiding my warranty?

User avatar
malakai
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am
Contact: Website

Re: No overclock option in raspi-config

Sun Jan 13, 2013 2:23 am

That's a tough question the wiki on it is here:

http://elinux.org/RPiconfig#Overclocking
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)

Yamahanytro
Posts: 13
Joined: Wed Jan 02, 2013 10:22 pm

Re: No overclock option in raspi-config

Sun Jan 13, 2013 2:33 am

malakai wrote:That's a tough question the wiki on it is here:

http://elinux.org/RPiconfig#Overclocking
I want to use the Raspi-config Overclocking so it does not void the warranty. But that option is not on the config! But if I use another one of my SD cards I have Rasbian installed on The options is there. Im trying to find out how to get that option back.

dgately
Posts: 4
Joined: Thu Jul 12, 2012 5:21 pm

Re: No overclock option in raspi-config

Fri Jan 25, 2013 5:05 am

Try:

Code: Select all

sudo apt-get -y remove raspi-config
sudo apt-get -y install raspi-config
Even when apt-get stated that I had the latest version of raspi-config, it was running an older version. The remove and install seems to correct the problem for me. I also used berryboot, so this should help you...

dgately

netninja
Posts: 5
Joined: Fri Feb 08, 2013 12:16 am

Re: No overclock option in raspi-config

Thu Apr 04, 2013 12:17 pm

dgately wrote:Try:

Code: Select all

sudo apt-get -y remove raspi-config
sudo apt-get -y install raspi-config
Even when apt-get stated that I had the latest version of raspi-config, it was running an older version. The remove and install seems to correct the problem for me. I also used berryboot, so this should help you...

dgately
This worked for me... Using 03/2013 berryboot and 12/2012 raspbian distro. Thanks for the tip!

strasharo
Posts: 15
Joined: Thu Jan 24, 2013 6:09 pm

Re: No overclock option in raspi-config

Wed Apr 24, 2013 12:46 pm

You'll have also to mount manually your boot partition in Berryboot prior using raspi-config, so it can write to /boot/config.txt

Code: Select all

mount -t auto /dev/mmcblk0p1 /boot

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 24 guests