glint-nes Jan. 2013 release - download and demo video

50 posts   Page 1 of 2   1, 2
by normalocity » Mon Jan 07, 2013 4:16 am
Okay, the video is probably still uploading, but should be done in about an hour after this post.


While you're waiting go download our pre-built SD card image, which is available now!


The January beta release includes a couple of new, really cool features:

* Boots directly into our customized graphical front end - based on Aloshi's EmulationStation
* Plug a USB stick into your Raspberry Pi and it will automatically copy any ROM (*.nes) files over for you!
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by normalocity » Mon Jan 07, 2013 8:03 pm
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by jlongstreet » Mon Jan 07, 2013 8:52 pm
Looks great!

I'm curious about a couple of things:

You mention that there's currently no way to exit RetroArch without the keyboard. It looks like a method like ... 1065#p1065 would be useful: set input_enable_hotkey_btn to, say, Select, and then set input_exit_emulator_btn to A or B.

Could there be reboot/shutdown options added to the start menu in your emulationstation fork?

What work remains in order to get two controllers working for two-player games? I'd be more than willing to contribute some work to the project. I'll need to get some proper controllers, since currently I'm using Xbox 360 controllers which require a flaky userspace driver, but I'm planning on doing that eventually anyway. Which controller are you using?

I think I remembered you mentioning a while back that you planned on making versions of glint for other systems -- SNES, Genesis, etc. I'd also be interested in working on this. Do you have a base image you start from, or a script or list of packages to install and uninstall starting from base Raspbian?

My plan is to have a Pi hooked up to my TV that boots directly to a frontend, can be navigated using only original controllers (or clones of them), and plays games from as many systems as makes sense. RetroArch/RetroPie are nice, but I'm starting to come around to the idea of one SD card per system.
Posts: 31
Joined: Wed Sep 05, 2012 2:59 am
by normalocity » Mon Jan 07, 2013 9:22 pm
Thanks for the tip on the hotkeys. I think we misunderstood how they worked, so therefore we were using them incorrectly. I'll open a project issue to try this.

As for adding the reboot/shutdown option, sure I can do that. I actually took them out, mostly because I didn't find them useful, but it should be easy enough to add back.

Regarding the issue with supporting two players: we think it's a matter of getting an updated FCEU binary into the project ( at it appears that the bug preventing two-player support has been patched. A few hours ago someone stepped up and offered to start maintaining updated binaries for us that are based on builds from the latest source code. I hope this "no two player support" thing will be resolved by the next release (we're trying to get onto a monthly release schedule).

Regarding future system support: I'm going to start working on new systems (SNES, Genesis, etc.) when we're at or near 100% of our stable release goals. You can see the progress of the beta ( We basically have some polishing to do right now and a couple of relatively minor bugs to patch. We're close to a decent stable release. It should be noted that when I say "we're close," I don't mean we're going to be done tomorrow or anything. We're close in terms of the number of releases between now and a stable release (maybe fewer than 5 monthly releases?). In the meantime, of course, download our OS image, test it out, and let us know what's broken so we can fix it!

Regarding a base image, there are two ways to get a working glint-nes box (do only one of them, don't try to combine them):

1. Easy way: download our latest pre-built image and start from there:
2. Hard(er) way: download the Official Dec. 16th Raspbian image ( ... and run our install script (

If you go with #2, please be aware of open bugs! If you're running the install script yourself then you're basically accepting the burden of some extra troubleshooting if it doesn't work, so make sure you're up for it.

Bug list: ... state=open
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by jlongstreet » Mon Jan 07, 2013 10:22 pm
Awesome, that's exactly what I was looking for. If it wouldn't step on your toes too much, would you mind me setting up a branch to work on glint-snes?
Posts: 31
Joined: Wed Sep 05, 2012 2:59 am
by normalocity » Mon Jan 07, 2013 10:31 pm
You're welcome to fork the project on GitHub, which is the default way to collaborate. From there any changes you make can be put into a "Pull Request" to be reviewed before being merged into the main project. Within your forked repo you can do as you please without affecting releases, yet still communicate with us if you think something should be merged into the main project. :D

Feel free to write me emails directly if you run into problems or want to know if something is already being worked on. Also, if your intent it to contribute to the project directly (e.g. modifications that you want to have pushed back into the main project) then please do get in contact with me to make sure we're all pulling in the same direction.

I haven't really thought much about how to structure additional system support. My initial thought was to create one repo per system, as I planned on distributing on SD card per system, custom configured to that system. However, I have some concerns about that kind of a splintered approach and am open to other suggestions.
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by kevkaos » Mon Jan 07, 2013 10:41 pm
all boots ok but when in frontend i have no power to my keyboard (dont have a game pad yet)
cant exit or do any thing just have to power off :cry: not sure what to do
Posts: 16
Joined: Sat Apr 21, 2012 7:00 am
by normalocity » Mon Jan 07, 2013 10:45 pm
Do any of the following keys do anything (specifically, the F4 key)?

Up - Scroll up
Down - Scroll down
Left - Last system (if it exists)
Right - Next system (if it exists)
Enter - Select
Escape - Back out of a folder
F1 - Open the restart/shutdown system menu
F2 - Open the fast select dialog
F4 - Close glint-es (should work as long as ES hasn't frozen)
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by normalocity » Mon Jan 07, 2013 10:50 pm
If the actual power to your keyboard is off (for example, pressing the CAPS Lock key doesn't turn your Caps Lock light on/off), then I'm not sure I can help you there. Check your power supply, and confirm that your keyboard works with the stock Raspbian image and let me know what happens.

Also, make sure your keyboard is compatible. There are a lot of keyboards that just don't work with Raspbian, or have flaky results. The glint-nes OS image comes pre-setup with a US keyboard layout, which may also be causing a problem for you if you're not using a US keyboard.

Here's just one example of keyboard issues: viewtopic.php?f=28&t=21809
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by cpowers » Wed Jan 09, 2013 12:29 am
Before i order a controller, have you tested any 'universal' controllers or maybe the snes controller Like this?

Chris ... controller
Posts: 2
Joined: Mon Jan 07, 2013 12:17 am
by normalocity » Wed Jan 09, 2013 1:46 am
I haven't used that specific controller, but we do have a link to the "official" controller in the help topic below. There are also instructions on how to add support for any controller that works with Linux - it's basically just a config file, and a matter of mapping button #s to functions. Pretty easy.!topic ... 78ytgrA20I

Any issues you run into you can email me, and I'll do what I can to help fix it.

This SNES controller you link to looks like a good option for a future SNES project. I'll probably buy one in February and try it out.
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by jlongstreet » Wed Jan 09, 2013 4:54 pm
When the come in the mail (within the next week) I'm going to be testing some USB adapters for NES and SNES controllers, since I have 2 original NES and 1 original SNES controller already. I'll post my results and input configurations here.
Posts: 31
Joined: Wed Sep 05, 2012 2:59 am
by normalocity » Wed Jan 09, 2013 4:56 pm
That should work - one of the project contributors is using an adapter for the original controllers.
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by Woyote » Fri Jan 11, 2013 2:31 am
Encountering a significant snag here.

Inserting the USB stick to auto-scan results in the Pi rebooting. This has been pretty consistent.

The Pi boots fine with the USB stick already inserted, but then the auto-mount doesn't kick in once the emulator boots.

Any idea what's up there? I'm still very new to Linux and the Pi, so I'm not sure how to get around this.
Posts: 3
Joined: Fri Jan 11, 2013 2:27 am
by normalocity » Fri Jan 11, 2013 5:20 pm
That happened to me once when I was inserting the USB and steadying the Pi by placing my finger on the back of the USB port. My guess (at least in my case) is that I was creating an electrical short. I was also using a USB stick that had an all-metal case, which I think added to the issue.

Basically, double check that you're only touching the non-conductive parts of the Pi when you insert the USB stick (or that it's in a case), and let me know if that makes any difference.
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by pyre » Sat Jan 12, 2013 4:05 am
Hey, thanks alot for this. Works great.

I just wanted to post a quick reply about the issue with a USB stick restarting the Pi.

I had the same issue with 2 separate generic cheapo USB sticks, but since then I have been successful with a Sandisk branded USB stick and it doesn't reset the device and is working fine.

Something to try for people having the reset issue.
Posts: 3
Joined: Tue Jan 08, 2013 5:46 am
by normalocity » Sat Jan 12, 2013 1:51 pm
Thanks. Cross-posted this to our glint-help group:!topic ... a-KzqB9tBs
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by pyre » Sun Jan 13, 2013 9:37 pm
Just a quick question, how am I able to change the resolution of the games list/menu? The top of the menu is cut off a bit on one of the TV's I use. In game it is fine and at startup it seems to be fine as well.
Posts: 3
Joined: Tue Jan 08, 2013 5:46 am
by normalocity » Mon Jan 14, 2013 2:58 am
You can try adjusting the framebuffer width/height, or playing with the overscan and related settings.


While glint-nes does not specify any particular resolutions settings ( ... config.txt), and use whatever the Pi does by default, you're not the first person to report such issues so I would be curious to know more.

Out of curiosity, on which side(s) does it cut off? Top, bottom, left right?
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by Woyote » Mon Jan 14, 2013 5:11 am
So, some further research turned up that some Pi boards will reset on inserting a USB drive, due to voltage issues. I've got one of those, it seems. This makes the Glint-NES auto-load pretty much useless to me.

I figured I would be clever, and just copy all the files over from the command line. I was really disappointed to find that this doesn't work - I get the same prompt telling me in insert a USB stick. Looking again, the files I'd copied (using -a, for the record) were removed from the roms directory.

Does Glint-NES not store roms? Do you have to insert a key every time? This is obviously not going to work in my case.

It also won't look at SD cards entered via USB readers, etc.

The auto load feature is awesome from a plug and play angle, but it shouldn't be the only method. Any help on this?
Posts: 3
Joined: Fri Jan 11, 2013 2:27 am
by pyre » Mon Jan 14, 2013 5:16 am
I tried playing with those overscan settings and no dice, it doesnt appear to affect anything in the menu.

It cuts off the top heres a pic:
Posts: 3
Joined: Tue Jan 08, 2013 5:46 am
by iain1970 » Mon Jan 14, 2013 10:56 am
I loaded the software up last night and loaded one ROM via USB no problem.

I use a 256MB Pi and also have the screen cut off at the top (HDMI into a full HD telly). Not a problem really, but odd.

However, my generic USB game pad from PC World doesn't work at all. It has the d-pad, four SNES type fire buttons and four shoulder buttons. It works on my Android tablet and PC. Can I get into the software to allocate buttons?
Posts: 18
Joined: Mon Jul 02, 2012 9:10 am
by mrfunk » Mon Jan 14, 2013 2:09 pm
thanks for the great emulator, is it possible to play with keyboards ? I tried 2 brands (microsoft & a-tech) but it doesn't work.
Posts: 5
Joined: Tue Aug 07, 2012 8:54 am
by normalocity » Mon Jan 14, 2013 2:54 pm

Regading the resets: First make sure you're not touching any conductive portions of the RPi when you insert a USB stick (e.g. the back of the ports, like I did, which caused my own RPi to reset). When I placed my fingers only around the edges of the board it was fine.

Second, I use a 5v/2a power supply, so there's plenty of extra power. Can't emphasize enough how important it is to have a power supply that has some juice to spare in order to not have resets and other power problems when inserting devices.

Regarding the copying of ROMs manually: The prompt at the top saying "Add ROMs via USB stick is there to let you know that you can always add ROMs that way. If you seem ROMs in your list (as I see you have in your screenshot) then your ROMs are on the Pi. The prompt is meant to indicate that you can always add more ROMs by inserting a USB stick with ROMs on it.

glint-nes does definitely store ROMs - it copies whatever is on your USB stick to the /home/pi/roms folder. After you see the list of games appear you can safely remove the USB stick and you don't need it again - the ROMs are on your SD card at that point.

There is a bug ( where, when you insert a USB stick, it replaces instead of adding ROMs to the list. That's our bad, and it should be fixed in the next release. The intent is that you can always add more ROMs in the future, but as you've observed, and several other people have reported, it replaces rather than copies new ROMs into place. We'll get this fixed.

Regarding SD cards via USB readers: This is an option we hadn't yet considered, though not a bad idea. We need to alter the auto-mount/auto-copy script to support it. I may have a USB reader sitting around somewhere, so I'll take a look into it.

I've opened a case for this to investigate:
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm
by normalocity » Mon Jan 14, 2013 3:02 pm

Does the D-pad work inside the menu at least? For example, without doing any configuration can you go up/down?

Basically you need to find out if your gamepad works with Linux at all. If it doesn't and/or you don't have drivers for it, I can't guarantee it will work. In the next release of glint-nes we will no longer come with a pre-configured joystick, and on first run will prompt you to configure your controller so that people can use any controller that works with Linux, and have a decent experience. It adds a step to the setup of your emulation experience, but we've seen that people are using a wide variety of controllers with this thing, and having a pre-configured joystick setup that doesn't work universally is causing more problems then it's apparently worth.

The original idea was to have everyone on the same controller hardware to help mitigate this problem. Specifically, this one: ... B0034ZOAKO

However, that doesn't work either because we've found that the hardware button assignments change from one person to the next, as the manufacturer changes the internals of the controller circuit board. Since we have no control over the supply of controllers and cannot guarantee that buttons will be mapped out exactly the same for everyone, the only real option we have is to have everyone configure their joystick the first time they run the emulator.

In order to get your specific controller working, right now it's a bit of a pain, and I hope to correct this in the next release or two. Right now the best option is to try the following help article:!topic ... 78ytgrA20I
Posts: 49
Joined: Tue Jun 19, 2012 2:34 pm