Posts: 2
Joined: Sat Aug 01, 2020 2:18 am

Steam Error Pi 4

Thu Aug 06, 2020 2:34 am

Hello! After downloading and installing Steam for Linux from the official Steam website, I ran the program. However, it gave me an error message as follows: "You are missing the following 32-bit libraries, and Steam may not run:" I have no clue how to install this package, and have tried

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get upgrade
to no avail. Does anyone have a fix for this?

User avatar
Posts: 4331
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia
Contact: Twitter

Re: Steam Error Pi 4

Thu Aug 06, 2020 3:29 am

Steam, the video game client software, is for an x86 CPU, but the Pi uses an ARM CPU.
It will not work and there is nothing you can do to make it work satisfactorily.

There is Steam Link, but that requires steam installed and running on an external x86 based PC and a sufficiently speedy network connection - at which point... Just play your games on that pc?

Rose tinted glasses are difficult to see through.

Posts: 225
Joined: Tue May 19, 2015 2:49 pm

Re: Steam Error Pi 4

Thu Aug 06, 2020 8:05 am

I guess you are using box86 to run Steam.
That error message is "normal", just press "ok" to continue. You can avoid it by defining "STEAMOS=1" environement variable.

Note that steam is still a bit of hit and miss. It should work with box86, but may crash often. Also, remember that you need to use "mini mode" to get the list of game. Regular mode will show an empty list of game.

Return to “Gaming”