spcharc
Posts: 30
Joined: Tue Jul 02, 2019 12:23 am

Poor bluetooth audio quality playing with VLC player

Mon Jul 13, 2020 4:49 am

I am experiencing terrible audio quality with my bluetooth headset. The audio format is ".flac"
The device is a Pi 3B, running latest raspbian buster.
At first I thought it's a hardware problem. I tried disabling on-board WiFi as some posts suggested it may cause bluetooth connection issue. But the audio quality is still poor.
Until I tried:

Code: Select all

ffmpeg -i XXX.flac -f s16le -ar 44100 -ac 2 - | aplay -f cd -
this time the quality is much better.
I want to know why this happens.
The VLC player supports far more audio formats than "aplay" so I don't need "ffmpeg" to do conversion. And it can play videos too. If possible I want to use VLC instead of "aplay".

spcharc
Posts: 30
Joined: Tue Jul 02, 2019 12:23 am

Re: Poor bluetooth audio quality playing with VLC player

Tue Jul 14, 2020 3:50 am

Reason found!
It's because the volume bar in VLC is dragged to 125%. I've tried so many options in VLC without thinking about the volume.
I found out that if the volume is above 100%, the quality would be poor.
So
(125% in VLC + 40% system wide volume) != (100% in VLC + 50% system wide volume)

So it turns out to be a volume problem. And I still don't understand why volume setting can cause this problem.

Jozzey07
Posts: 28
Joined: Sat Jul 11, 2020 12:51 am

Re: Poor bluetooth audio quality playing with VLC player

Tue Jul 14, 2020 4:20 am

How did you connect your Bluetooth headset to your raspberry pi, i haven't been able to figure it out

spcharc
Posts: 30
Joined: Tue Jul 02, 2019 12:23 am

Re: Poor bluetooth audio quality playing with VLC player

Thu Jul 16, 2020 10:59 pm

Jozzey07 wrote:
Tue Jul 14, 2020 4:20 am
How did you connect your Bluetooth headset to your raspberry pi, i haven't been able to figure it out
I just did this:

Code: Select all

pi@raspberrypi:~ $ bluetoothctl
[bluetooth]# scan on
Wait until your device appeared (remember to put it into pairing mode)

Code: Select all

[bluetooth]# pair XX:XX:XX:XX:XX:XX
[bluetooth]# connect XX:XX:XX:XX:XX:XX
[bluetooth]# trust XX:XX:XX:XX:XX:XX
Then right click on the volume icon at the top right, choose your headset as the sound output

Return to “General discussion”