autosaver
Posts: 4
Joined: Thu Dec 27, 2012 11:09 pm

scummvm no sound

Fri Dec 28, 2012 6:31 pm

Hello!

Running fresh 2012-12-16-wheezy-raspbian.
Have installed scummvm with apt-get scummvm-data scummvm

no sound from any of my games

root@raspberrypi:~# lsmod
Module Size Used by
snd_seq_dummy 1592 0
snd_bcm2835 12808 1
snd_pcm 74834 1 snd_bcm2835
snd_seq 52536 1 snd_seq_dummy
snd_timer 19698 2 snd_seq,snd_pcm
snd_seq_device 6300 2 snd_seq,snd_seq_dummy
snd 52489 7 snd_seq_device,snd_timer,snd_seq,snd_pcm,snd_bcm2835
snd_page_alloc 4951 1 snd_pcm
evdev 8682 3

tried to install and reinstall required libs (src scummvm.org)
Required Libraries
SDL 1.2.x
Optional Libraries
MAD: MPEG Audio Decoder
Ogg Vorbis
FLAC: Free Lossless Audio Codec
FAAD2: MPEG-4 and MPEG-2 AAC Decoder
Theora: Theora Decoder
zlib: Data Compression
FluidSynth: Real-Time Software MIDI Synthesizer

Can play sound with other apps like mplayer

Only one line after exiting scummvm
"WARNING: SDL mixer output buffer size: 1024 differs from desired: 2048"

Tried google for some time now but find no sollution. Can any one help?
Thanks.

DallasPi
Posts: 2
Joined: Sat Dec 29, 2012 10:42 pm

Re: scummvm no sound

Sat Dec 29, 2012 10:44 pm

I am experiencing same issue. Kids really want to play spyfox too :(

chalkers123
Posts: 1
Joined: Sun Dec 30, 2012 12:24 am

Re: scummvm no sound

Sun Dec 30, 2012 12:30 am

Its an epidemic now. I cant get sound either.

Have tried looking for solution with no reply.... help us please....

fredcop
Posts: 5
Joined: Thu Jan 03, 2013 1:50 pm

Re: scummvm no sound

Thu Jan 03, 2013 6:39 pm

Hey there!
Experiencing the same issue as you guys - games works, except for sound. So far I have only tried ScummVM (with Day of the Tentacle) and Beneath a Steel Sky (via apt-get install).

Tried messing around with the sound settings in ScummVM, nothing. No sounds, speech or music at all.
I also tried switching output to HDMI or audio jack, still nothing. Sound works perfectly with aplay and omxplayer.

Ideas, anyone?

fredcop
Posts: 5
Joined: Thu Jan 03, 2013 1:50 pm

Re: scummvm no sound

Thu Jan 03, 2013 10:17 pm

Update: I got the sound to work by running:

Code: Select all

sudo /usr/games/scummvm
Is there any way to change this? Sound doesn't work when running ScummVM from the desktop (or without sudo). I'm a beginner, sorry for asking something that's probably obvious! :)

fredcop
Posts: 5
Joined: Thu Jan 03, 2013 1:50 pm

Re: scummvm no sound

Thu Jan 03, 2013 11:33 pm

Update 2: It also seems like audio do not work with ScummVM if you run it from a terminal-window in the desktop, sudo or not. When audio do not work, ScummVM reports: "WARNING: SDL mixer output buffer size: 1024 differs from desired: 2048!"

When sound is working, it does not produce the warning.

Is it some kind of problem with user access?

fredcop
Posts: 5
Joined: Thu Jan 03, 2013 1:50 pm

Re: scummvm no sound

Fri Jan 04, 2013 6:18 pm

Update 3: I've been messing around a bit more, from what I can see the permissions should be ok, user pi is member of group audio. There is something going on in the background with root access. :|

autosaver
Posts: 4
Joined: Thu Dec 27, 2012 11:09 pm

Re: scummvm no sound

Mon Jan 07, 2013 9:39 pm

Glad you found out it can be run as sudo, I did't think of that.
Tried changing some permissions, play around and added user pi to some groups but with no success.
I'm glad to have it working with sound anyhow, hope to be abel to do it without sudo in the future.

Thanks

autosaver
Posts: 4
Joined: Thu Dec 27, 2012 11:09 pm

Re: scummvm no sound

Thu Jan 10, 2013 5:53 pm

Update

Tried to compile scummvm1.5 (standard, ./configure, make) with same result.
Problem is some where else.

Magic Knight
Posts: 29
Joined: Sat Jan 12, 2013 5:14 pm

Re: scummvm no sound

Sat Jan 12, 2013 5:34 pm

RPi online !
This worked for me.
sudo apt-get --yes purge pulseaudio
I think it removes the pulseaudio package, then ALSA is used instead. Now got sound in Beneath a Steel Sky.
I installed scummvm with sudo apt-get install scummvm
Google for scumm games.
Have fun.
Magic Knight

fredcop
Posts: 5
Joined: Thu Jan 03, 2013 1:50 pm

Re: scummvm no sound

Sun Jan 13, 2013 2:30 am

I've tried removing pulseaudio, works for sound effects and speech. Unfortunately, midi music is missing instead. Sudo still works better, unless I'm missing something.

autosaver
Posts: 4
Joined: Thu Dec 27, 2012 11:09 pm

Re: scummvm no sound

Wed Jan 16, 2013 9:12 pm

Got a workaround

in /etc/default/pulseaudio
Change PULSEAUDIO_SYSTEM_START=0 to 1
and reboot

I have no idea how this will affect the rest of the system, but it worked with scummvm :)

Pixman
Posts: 3
Joined: Fri Feb 13, 2015 10:44 pm

Re: scummvm no sound

Sat Feb 14, 2015 6:53 am

Did this work for ANYBODY? I got no audio output, yet.

I tried everything that was recommended here.
Also put theaudio through ALSA in the scummvm config.
Then it opens the ALSA channel ithout a problem as you can see in my logs:

Code: Select all

spi@hungary ~ $ scummvm 
WARNING: SDL mixer output buffer size: 1024 differs from desired: 2048!
User picked target 'sky' (gameid 'sky')...
  Looking for a plugin supporting this gameid... Sky
  Starting 'Beneath a Steel Sky'
Found BASS version v0.0372 (5097 dnr entries)
Connected to Alsa sequencer client [14:0]
ALSA client initialized [128:0]
pi@hungary ~ $ scummvm ^C

But audio szays mute. Sound in every other application works perfect, but scummvm, no.
Not even with ROOT access, there is any sound...

agazendam
Posts: 1
Joined: Tue Sep 06, 2016 8:00 am

Re: scummvm no sound

Tue Sep 06, 2016 8:14 am

I can confirm that uninstalling pulseaudio resolved my problem.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 46 guests