ikk
Posts: 63
Joined: Sat Feb 09, 2019 12:39 am

Ubuntu 20.04 LTS screen too large to fit tv issue

Fri Apr 17, 2020 7:37 pm

Hello,

Ever since I bought my raspberry pi 4B, i noticed an issue with the screen being too big to fit my tv and ends up being cut off from the edges (this was not an issue with my 3B+). However, on raspbian, adding “dtoverlay=vc4-fkms-v3d” to config.txt did the trick.

But, with Ubuntu 20.04 LTS, doing the same didn’t seem to work at all. Same goes with adding “disable_overscan=1” to the usercfg.txt (same outcome using config.txt even though for ubuntu it clearly says to not modify config.txt and use usercfg.txt instead).

I tried everything I could possibly find online to no avail. And the Ubuntu community don’t seem to respond. So I figured you guys would know better about the raspberry pis anyway.

Here’s my current setup:

Raspberry Pi 4B 4GB RAM (first version)
64GB SANDISK A2 SD Card
Ubuntu 20.04 LTS (64-bit ARM) from here: (http://cdimage.ubuntu.com/ubuntu-server ... EADER.html)
1920x1080 TV (with no setting for overscan... i tried every one of its few settings and none have anything to do with overscan... i even tried all the hdmi ports)

I’m looking forward to your help

Thanks

User avatar
waveform80
Posts: 359
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK
Contact: Website Twitter

Re: Ubuntu 20.04 LTS screen too large to fit tv issue

Sat Apr 18, 2020 3:03 pm

If the display is falling off the edges then you want overscan enabled (in other words, the opposite of "disable_overscan=1"). For some reason our default framebuffer (the one without the FKMS overlay) seems to disable overscan implicitly (I suspect something to do with u-boot that I haven't had time to dig into yet). Anyway, what you want to do is:
  • Make sure you've got dtoverlay=vc4-fkms-v3d in syscfg.txt or usercfg.txt (as you've noted, try not to modify config.txt - we might overwrite that).
  • Make sure you don't have disable_overscan=1 in those files (or ensure it's disable_overscan=0 which is the default).
If the image is still falling off the edges then you may have an unusual amount of overscan on your display in which case you need to increase the overscan margins. You can do this with the "overscan_top", "overscan_left", "overscan_bottom", and "overscan_right" settings. I vaguely recall the default is 24 so try larger values than that until you get something satisfactory.

Hope that helps!

Dave.
Author of / contributor to a few pi related things (picamera, Sense HAT emulator, gpio-zero, piwheels, etc.), and currently a software engineer at Canonical responsible for Ubuntu Server and Core on the Raspberry Pi.

ikk
Posts: 63
Joined: Sat Feb 09, 2019 12:39 am

Re: Ubuntu 20.04 LTS screen too large to fit tv issue

Sat Apr 18, 2020 5:56 pm

waveform80 wrote:
Sat Apr 18, 2020 3:03 pm
If the display is falling off the edges then you want overscan enabled (in other words, the opposite of "disable_overscan=1"). For some reason our default framebuffer (the one without the FKMS overlay) seems to disable overscan implicitly (I suspect something to do with u-boot that I haven't had time to dig into yet). Anyway, what you want to do is:
  • Make sure you've got dtoverlay=vc4-fkms-v3d in syscfg.txt or usercfg.txt (as you've noted, try not to modify config.txt - we might overwrite that).
  • Make sure you don't have disable_overscan=1 in those files (or ensure it's disable_overscan=0 which is the default).
If the image is still falling off the edges then you may have an unusual amount of overscan on your display in which case you need to increase the overscan margins. You can do this with the "overscan_top", "overscan_left", "overscan_bottom", and "overscan_right" settings. I vaguely recall the default is 24 so try larger values than that until you get something satisfactory.

Hope that helps!

Dave.
Thank you very much for your detailed help!

I’ve already tried setting disable_overscan=0 with the same outcome.

However, while looking at the usercfg.txt, I remembered something.

The guide that I used to install ubuntu desktop 20.04LTS from the Ubuntu server image mentioned adding the following to the usercfg.txt to set the resolution to 1080p:

hdmi_group=2
hdmi_mode=82

So I thought I’d try removing that... and sure enough, that fixed it!

Then I added:

hdmi_group=1
hdmi_mode=16

And when i tried that, i no longer get the issue!

No clue what’s different between the two hdmi groups that will make group 1 work but group 2 cause the issue.

User avatar
waveform80
Posts: 359
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK
Contact: Website Twitter

Re: Ubuntu 20.04 LTS screen too large to fit tv issue

Thu Apr 23, 2020 10:24 am

ikk wrote:
Sat Apr 18, 2020 5:56 pm
No clue what’s different between the two hdmi groups that will make group 1 work but group 2 cause the issue.
HDMI group 1 consists of the CEA (Consumer Electronics Association) modes; these are modes typically used on TVs. HDMI group 2 is DMT (Display Monitor Timings); these modes are typically used on computer monitors. The overscan defaults change depending on whether the mode is 1 (in which case the overscan is some positive amount) or 2 (in which case the overscan defaults to 0 because monitors usually don't have any).

I should've added a note about that last time, but I couldn't remember the specific details (despite looking them up only a couple of months ago!). Anyway (having looked it up again!), the full details are under "disable_overscan" on https://www.raspberrypi.org/documentati ... t/video.md :
Set disable_overscan to 1 to disable the default values of overscan that is set by the firmware. The default value of overscan for the left, right, top, and bottom edges is 48 for HD CEA modes, 32 for SD CEA modes, and 0 for DMT modes. The default value for disable_overscan is 0.
So, I was wrong about the default being 24!
Author of / contributor to a few pi related things (picamera, Sense HAT emulator, gpio-zero, piwheels, etc.), and currently a software engineer at Canonical responsible for Ubuntu Server and Core on the Raspberry Pi.

ikk
Posts: 63
Joined: Sat Feb 09, 2019 12:39 am

Re: Ubuntu 20.04 LTS screen too large to fit tv issue

Thu Apr 23, 2020 12:07 pm

waveform80 wrote:
Thu Apr 23, 2020 10:24 am
ikk wrote:
Sat Apr 18, 2020 5:56 pm
No clue what’s different between the two hdmi groups that will make group 1 work but group 2 cause the issue.
HDMI group 1 consists of the CEA (Consumer Electronics Association) modes; these are modes typically used on TVs. HDMI group 2 is DMT (Display Monitor Timings); these modes are typically used on computer monitors. The overscan defaults change depending on whether the mode is 1 (in which case the overscan is some positive amount) or 2 (in which case the overscan defaults to 0 because monitors usually don't have any).

I should've added a note about that last time, but I couldn't remember the specific details (despite looking them up only a couple of months ago!). Anyway (having looked it up again!), the full details are under "disable_overscan" on https://www.raspberrypi.org/documentati ... t/video.md :
Set disable_overscan to 1 to disable the default values of overscan that is set by the firmware. The default value of overscan for the left, right, top, and bottom edges is 48 for HD CEA modes, 32 for SD CEA modes, and 0 for DMT modes. The default value for disable_overscan is 0.
So, I was wrong about the default being 24!
Well hey! This was a learning experience for the both of us! Thank you very much for the info. I appreciate your help!

Return to “Ubuntu”