jam75
Posts: 17
Joined: Wed Nov 06, 2019 6:35 pm

PI 4 no sound on jack

Thu Mar 26, 2020 3:43 pm

Hi,
I have several pi's working without any problem of sound, but on a pi 4 under raspbian, the only way to produce sound on the jack interface is using :

“omxplayer -o local sample.mp3”

I must say that “./hello_audio.bin” produces a sound too.

But VLC, KODI, speaker-test do not produce any sound.

If I use a headset connected via USB, no problem : the sound is normal.

Thanks for your help.
Best regards

User avatar
neilgl
Posts: 1609
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near Aston Martin factory

Re: PI 4 no sound on jack

Thu Mar 26, 2020 11:07 pm

What I do is connect a speaker on the 3.5mm jack, then select Analog (not HDMI) on the sound icon in the top right hand menu bar.
pi4 running Raspbian Buster latest version (same on pi3).

sora03
Posts: 250
Joined: Mon Dec 29, 2014 4:11 pm
Location: Philippines
Contact: Website YouTube

Re: PI 4 no sound on jack

Fri Mar 27, 2020 12:01 am

You can set the default audio output (HDMI/3.5mm) by using raspi-config (if you are using headless/no GUI)
Mastodon: https://mastodon.social/@ssora

skyroma
Posts: 1
Joined: Fri Mar 27, 2020 7:19 am

Re: PI 4 no sound on jack

Fri Mar 27, 2020 12:31 pm

I have the same problem on my raspberry pi4. No sound via 3.5 jack. I set the default audio output 3.5mm by using raspi-config, but no effect.

jam75
Posts: 17
Joined: Wed Nov 06, 2019 6:35 pm

Re: PI 4 no sound on jack

Fri Mar 27, 2020 3:28 pm

Thanks for the answers.
I tried all suggested solutions...

sora03
Posts: 250
Joined: Mon Dec 29, 2014 4:11 pm
Location: Philippines
Contact: Website YouTube

Re: PI 4 no sound on jack

Sun Mar 29, 2020 4:26 am

jam75 wrote:
Fri Mar 27, 2020 3:28 pm
Thanks for the answers.
I tried all suggested solutions...
can you open a terminal an use alsamixer to manipulate audio output.
You use the arrow keys.
Image
Mastodon: https://mastodon.social/@ssora

jam75
Posts: 17
Joined: Wed Nov 06, 2019 6:35 pm

Re: PI 4 no sound on jack

Sun Mar 29, 2020 9:04 pm

Thanks a lot,
here below is what I can get :

Image

Best regards

sora03
Posts: 250
Joined: Mon Dec 29, 2014 4:11 pm
Location: Philippines
Contact: Website YouTube

Re: PI 4 no sound on jack

Mon Mar 30, 2020 3:28 am

jam75 wrote:
Sun Mar 29, 2020 9:04 pm
Thanks a lot,
here below is what I can get :

Image

Best regards
press F6, then unmute some other audio output devices.
You can use arrow keys on your keyboard.
Mastodon: https://mastodon.social/@ssora

jam75
Posts: 17
Joined: Wed Nov 06, 2019 6:35 pm

Re: PI 4 no sound on jack

Mon Mar 30, 2020 9:35 am

yes,
that is what I did :
1. I have "pulseaudio" bu default.
2. with F6 I have:
2a. UJabra BIZ .../SB mixer : the sound is correct with the jeadset
2b. bcm2835 ALSA/Broadcom mixer: no sound on jack

Thanks again.
Best regards

fruitoftheloom
Posts: 21996
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: PI 4 no sound on jack

Mon Mar 30, 2020 9:39 am

jam75 wrote:
Mon Mar 30, 2020 9:35 am
yes,
that is what I did :
1. I have "pulseaudio" bu default.
2. with F6 I have:
2a. UJabra BIZ .../SB mixer : the sound is correct with the jeadset
2b. bcm2835 ALSA/Broadcom mixer: no sound on jack

Thanks again.
Best regards

I was not aware that PulseAudio was in Stretch / Buster, Bluez-Alsa is the default:

https://www.raspberrypi.org/blog/raspbian-stretch/

https://github.com/Arkq/bluez-alsa


Bluetooth audio

In Jessie, we used PulseAudio to provide support for audio over Bluetooth, but integrating this with the ALSA architecture used for other audio sources was clumsy. For Stretch, we are using the bluez-alsa package to make Bluetooth audio work with ALSA itself. PulseAudio is therefore no longer installed by default, and the volume plugin on the taskbar will no longer start and stop PulseAudio. From a user point of view, everything should still work exactly as before – the only change is that if you still wish to use PulseAudio for some other reason, you will need to install it yourself.
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

jam75
Posts: 17
Joined: Wed Nov 06, 2019 6:35 pm

Re: PI 4 no sound on jack

Mon Mar 30, 2020 3:03 pm

Thanks a lot.
I was not aware of pulseaudio case. I do not remember when I added it if it is not installed by default. I must hazve followed some solution prvided on another rasperry forum. I will check on my other PIs if pulseaudio is there.
Do you think I should remove pulse audio ?
Best regards

Return to “Troubleshooting”