plumpi
Posts: 56
Joined: Wed May 10, 2017 10:24 am

netbeans not working on full Raspian Buster

Wed Mar 25, 2020 5:55 pm

I have a 3B and I used the Pi Imager to install the latest full Raspbian on a 32G micro SD card.

I then refeshed the cache using
sudo apt-get update

To make sure everything was completely up-to-date I then did the following a couple of times;
sudo apt-get uprade

Next I installed netbeans;
sudo apt-get install netbeans

This worked fine and the netbeans 10 IDE could be run.
However it did not have C/C++ support.

It seems you need to load the plugin for version 8 of netbeans. In netbeans I ticked the box to get version 8 plugins and loaded C/C++.
I clicked install and everything went fine up to the very end when there was a fault. I ran netbeans and I could see C/C++ but it would not run. After I shutdown Rasbian the micro SD card not reboot - could be a coincidence but I am not so sure.

Sorry for not having actual error messages and screenshots, I am trying to recover from loss of the card as I have not been able to get a working re-install.

Anyway are there any known problems with using C/C++ in Netbeans with the latest Raspbian are there any tricks to getting it work?

fruitoftheloom
Posts: 22094
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: netbeans not working on full Raspian Buster

Thu Mar 26, 2020 8:20 am

plumpi wrote:
Wed Mar 25, 2020 5:55 pm
I have a 3B and I used the Pi Imager to install the latest full Raspbian on a 32G micro SD card.

I then refeshed the cache using
sudo apt-get update

To make sure everything was completely up-to-date I then did the following a couple of times;
sudo apt-get uprade

Next I installed netbeans;
sudo apt-get install netbeans

This worked fine and the netbeans 10 IDE could be run.
However it did not have C/C++ support.

It seems you need to load the plugin for version 8 of netbeans. In netbeans I ticked the box to get version 8 plugins and loaded C/C++.
I clicked install and everything went fine up to the very end when there was a fault. I ran netbeans and I could see C/C++ but it would not run. After I shutdown Rasbian the micro SD card not reboot - could be a coincidence but I am not so sure.

Sorry for not having actual error messages and screenshots, I am trying to recover from loss of the card as I have not been able to get a working re-install.

Anyway are there any known problems with using C/C++ in Netbeans with the latest Raspbian are there any tricks to getting it work?


Regards fully updating Raspbian Buster it is APT update / full-upgrade, see:

https://www.raspberrypi.org/documentati ... pdating.md
Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

Return to “Raspbian”