greenbike
Posts: 1
Joined: Sat Mar 21, 2020 2:46 pm

Minecraft Pi edition python control not working on Buster?

Sat Mar 21, 2020 2:59 pm

We recently upgraded our Pi 3B to Raspbian Buster, and the minecraft-pi python bridge does not seem to be working anymore. Any commands that communicate with the running minecraft-pi program return the text "unknown command: <whatever command we tried>"

To try to debug this further, I installed telnet and tried interacting directly with the server with the same results (see below)

Is this a known problem? We had it working before (on Stretch), and the only thing I can think of is the upgrade to Buster somehow broke something?

Here is a reproducible scenario:

1. Launch minecraft-pi from the Gaming menu. Create a new world and enter it.
2.

Code: Select all

telnet 127.0.0.1 4711
3. type

Code: Select all

chat.post(hello world)
and press enter
4. Response is:

Code: Select all

unknown command: chat.post(hello world)

---EOM---
I've tried many other commands, but I get the same "unknown command" message back. mcpi also has consistent errors like this - no commands seem to work, and draining the mcpi socket shows that the response was this same "unknown command" message.

Does anyone have the minecraft-pi python bridge working with Buster?

Return to “Gaming”