Unstable EDIMAX EW-7811UN Wireless dongle

11 posts
by kasperfm » Sat Dec 22, 2012 11:01 pm
Hello fellow Pi'ers :-)

I've tried all day to get my new EDIMAX EW-7811UN wireless dongle to work, but I failed...
I tried to download and compile the newest driver from Realtek, and I can see and connect to my WPA2-PSK network using the newest Raspbian build.
But my problem is that almost all packages are dropped.. I can't even ping my other machines on the network.

The signal is good, I use a powered USB hub.. and yea.. I can't find the problem.
I have even set up a static ip, and I can see the Pi device in my router's interface, but I can not even ping it.. :(
Posts: 5
Joined: Sat Dec 22, 2012 10:57 pm
by Wheel_nut » Sat Dec 22, 2012 11:18 pm
You don't need to fiddle with Drivers for the Edimax. Thr latest Raspbian Wheezy Download has the Drivers in the Kernel.

Are you using the WiFi Config utility in the LDXE GUI to configure your WiFi Connection?
Posts: 136
Joined: Tue Sep 18, 2012 7:51 pm
by kasperfm » Sat Dec 22, 2012 11:20 pm
Yes I am, but I can't use dhcp for the connection for some unknown reason.. So I tried setting up a static ip, but still no connection :-/
Posts: 5
Joined: Sat Dec 22, 2012 10:57 pm
by Wheel_nut » Sun Dec 23, 2012 12:19 am
Your OP says that you have downloaded and installed drivers ....

Start with a fresh install. Then use the Config options to set the RPi to boot straight into the LDXE GUI and then use the WiFi Config utility to scan for nad then set the WPA Passphrase. If it doesn't connect, post some screenshots here ....
Posts: 136
Joined: Tue Sep 18, 2012 7:51 pm
by tomexx » Sun Dec 23, 2012 1:20 am
I have the same dongle.Works out of the box.
You've change a bunch of settings, start with new install, run update. Then plug the dongle directly into pi and try setting up there. I'm running my without the hub.

Posts: 106
Joined: Thu Nov 01, 2012 4:58 pm
Location: Kitchener, ON, Canada, Earth
by kasperfm » Sun Dec 23, 2012 9:26 am
It's still not working here.. So here is a screenshot
Posts: 5
Joined: Sat Dec 22, 2012 10:57 pm
by tibi38 » Mon Dec 24, 2012 9:09 am
I have now the Model B and the December Image. Then I got no IP number using the GUI in connection with WEP. On Older Image (October) it had worked.
I got an error message with 'operation not permitted' by starting up the PI.
Any idea?
Admin of http://bed-and-breakfast-ungarn.de
Posts: 42
Joined: Sat Nov 10, 2012 8:46 am
Location: Europe
by kasperfm » Sun Dec 30, 2012 7:03 pm
I bought another dongle with an Atheros chip, because I ahd so much trouble with the Realtek one... :P
The new one works much better for me :)
Posts: 5
Joined: Sat Dec 22, 2012 10:57 pm
by dktak » Thu Jun 13, 2013 6:12 pm
I've had very similar challenges, updating driver, re-installing, whatever, and was very close at stopping my Raspi-project.

But now after exchanging the router, everything works like a dream. My conclusion is, that the Raspberry is much more sensible to unstable wifi, compared to fx. Windows that must have some recovery algorithms, as I had few Wifi-problems there.
Posts: 3
Joined: Thu Jun 13, 2013 6:04 pm
by kasperfm » Thu Jun 13, 2013 10:26 pm
I tried the dongle on a Mac actually, and had the same problems there.. until i disabled the QoS function. Then it worked fine :) Maybe you guys should try the same on RaspberryPi
Posts: 5
Joined: Sat Dec 22, 2012 10:57 pm
by notger.heinz » Fri Jun 14, 2013 1:58 pm
Fix: Use an USB-extension and place the dongle far away from the USB-ports and all other metal stuff impairing reception.

Had the same problem, until I stumbled upon a post that said it had something to do with the proximity to the USB-port. Also had VERY choppy keyboard and mouse input (used the Rapoo set plugged into the other USB port). After taking the measures described above, everything worked fine, though I still can't hide the dongle behind the TV set or behind some metal art thingy standing around. Or near the TV-antenna. ;)

If the other solution above works too, a short how-to for noobs like me would be nice.
Posts: 3
Joined: Fri Jun 14, 2013 1:42 pm