disable tap-to-click on touchpad


7 posts
by ogdenaggie » Sat Dec 22, 2012 8:05 am
Hello All,

I've searched around but can't find how to disable tap-to-click on a touchpad in Raspbian. I'm using a Motorola lapdock which works very well except for accidentally "clicking" with my palms while typing.

Googling has resulted in instructions for editing config files that don't exist in Raspbian. Is this possible with Raspbian or would it require a "bigger" distro?

Cheers,
OgdenAggie
Posts: 1
Joined: Sat Dec 22, 2012 8:01 am
by UnaClocker » Fri Jan 18, 2013 1:13 am
I'm working on the same problem myself. Since it's been a month, I'm curious if you found a solution to this problem? I'm almost ready to take the thing apart and unplug the touchpad and just use a mouse, but I like the clean look of using the touchpad that's built in.
I have found some mention of using "xinput", but I don't see any mention of tap clicking in there, nor any options that might do the trick for the problem.
Posts: 12
Joined: Sat May 12, 2012 5:48 pm
by thataintworking » Tue Nov 18, 2014 4:15 am
Did anyone ever figure this out? Tap-to-click is the most annoying "feature" since the touchpad itself.
Posts: 2
Joined: Tue Nov 18, 2014 4:12 am
by Tentbat » Mon Dec 29, 2014 6:22 am
Well, sort of. I was browsing the ridiculous paper instructions that came with my Logitech k400 (crazy, I know!) and discovered that for this model, holding down FN and then left clicking the trackpad turns off the tap to click. It is still early days, but rough measurements suggest that this makes the unit less annoying by 3 orders of magnitude. This isn't as good as a general Pi solution, but it suggests that for many keyboards, there is a way to fix the damn problem. Searching for solutions on the keyboard end seems like a good bet.

And no, I don't know what mental disorder you would need to have to make you think tap-to-click was a good feature to activate by default.
Posts: 2
Joined: Mon Dec 29, 2014 6:11 am
by 03ace » Wed Jan 07, 2015 3:36 pm
You guys are my heroes! Got my K400 yesterday and this was driving me crazy until I found it. Worked like a champ!
Posts: 1
Joined: Wed Jan 07, 2015 3:34 pm
by salsaman » Wed Jun 03, 2015 9:17 pm
THANK YOU THANK YOU THANK YOU!
I'm getting to this late but finally decided to follow every link I could find-- so much frustration out there.
Amazing that there's a feature built-in to the K400, just wonderful :)
Posts: 1
Joined: Wed Jun 03, 2015 9:16 pm
by 12characters » Mon Jul 13, 2015 10:57 pm
A very gracious thank you, I have been pulling out what little hair I have left trying to figure out how to turn off the way-oversensitive tap-to-click "feature". Read the manual... what a novel approach.Thanks for the reminder about something I should have known to do anyway.
Posts: 1
Joined: Mon Jul 13, 2015 10:49 pm