kshetline
Posts: 68
Joined: Thu Jun 07, 2018 3:17 am

I can't find the Geany debugger plugin anywhere

Sun Feb 02, 2020 5:08 am

I've found a few old posts on this subject, but nothing more recent than 2017.

I've done:

Code: Select all

sudo apt-get install geany-plugins
sudo apt-get install geany-addins
But no Geany debugger or Geany GBD shows up in the Geany Plugin Manager for me to select.

I've tried installing specific packages like geany-plugin-gdb, geany-plugin-debugger, and geany-plugin-scope -- none of those packages are found to even exist.

I've installed the Synaptic package manager, and I don't see anything that even fits into the category of a Geany debugger, and I've tried "apt-cache search geany" and don't see anything there either.

It it the case that there's simply no longer any Raspbian debugger plugin for Geany?

I first posted about this issue in the Beginners forum, but now that I see that there's a specific C/C++ forum, this is probably a better place for this subject.

I know there's a command line gdb tool, but I haven't done that style of debugging for ages (and I didn't much enjoy it back then either, even without having been spoiled by GUI debuggers yet.)

otani
Posts: 74
Joined: Fri Dec 13, 2013 4:18 am

Re: I can't find the Geany debugger plugin anywhere

Mon Feb 24, 2020 5:58 am

I have successfully installed the Geany plugin debugger Version 1.36.

viewtopic.php?f=82&t=265380#p1616642

Return to “C/C++”