giovangiuseppe
Posts: 5
Joined: Wed Jan 15, 2020 9:01 pm

SSH not work with Wi-Fi

Thu Jan 16, 2020 1:44 pm

Hi I'm Italian and sorry for my bad English, I have a problem with raspbian.

I connected my raspberry to Wi-Fi, but I can no longer connect, via SSH to the raspberry, if I am connected via Lan everything works.
I tried to set a static IP, but nothing has changed, I searched in various forums including this one and found this "article": [url] https://www.raspberrypi.org/forums/viewtopic.php?f = 28 & t = 138631 [/ url]

Advice? Do I send you my configurations?

Maze_fr
Posts: 43
Joined: Wed Dec 04, 2019 9:57 pm
Location: France

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 2:50 pm

Wifi 5G o wifi 2.4G ? RPi 0 / 2 / 3 / 4 ?

Col RPi 4 :
C'è un problema con il 2.4G quando c'è un USB3 HDD/SDD collegato.
Per utilizzare il 5G, devi scegliere il paese con raspi-config.

Edit : in english...

Wifi 5G or wifi 2.4G ? RPi 0 / 2 / 3 / 4 ?

With RPi 4 :
There's a problem the 2.4G when there's a plugged USB3 HDD/SDD.
In order to use the 5G, you must choose the country with raspi-config.
Last edited by Maze_fr on Thu Jan 16, 2020 3:38 pm, edited 1 time in total.
"Don't believe in forum signature quotations, they may be fakes" - Victor Hugo

DirkS
Posts: 10086
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 3:09 pm

Maze_fr wrote:
Thu Jan 16, 2020 2:50 pm
Wifi 5G o wifi 2.4G ? RPi 0 / 2 / 3 / 4 ?

Col RPi 4 :
C'è un problema con il 2.4G quando c'è un USB3 HDD/SDD collegato.
Per utilizzare il 5G, devi scegliere il paese con raspi-config.
This is the English section of the forum, so please respond in English

giovangiuseppe
Posts: 5
Joined: Wed Jan 15, 2020 9:01 pm

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 5:48 pm

Maze_fr wrote:
Thu Jan 16, 2020 2:50 pm
Wifi 5G o wifi 2.4G ? RPi 0 / 2 / 3 / 4 ?

Col RPi 4 :
C'è un problema con il 2.4G quando c'è un USB3 HDD/SDD collegato.
Per utilizzare il 5G, devi scegliere il paese con raspi-config.

Edit : in english...

Wifi 5G or wifi 2.4G ? RPi 0 / 2 / 3 / 4 ?

With RPi 4 :
There's a problem the 2.4G when there's a plugged USB3 HDD/SDD.
In order to use the 5G, you must choose the country with raspi-config.
I use a raspberry pi 3B+, wi-fi 2.4G and i choose the country with raspi-config

giovangiuseppe
Posts: 5
Joined: Wed Jan 15, 2020 9:01 pm

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 5:52 pm

This is my configuration
DHCPCD file

Code: Select all

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.
#duid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# Most distributions have NTP support.
#option ntp_servers

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate SLAAC address using the Hardware Address of the interface
#slaac hwaddr
# OR generate Stable Private IPv6 Addresses based from the DUID
slaac private

# Example static IP configuration:
# interface eth0
# static ip_address=192.168.1.23/134
# static ip6_address=fd51:42f8:caae:d92e::ff/64
# static routers=192.168.1.1
# static domain_name_servers=192.168.1.1 8.8.8.8 fd51:42f8:caae:d92e::1

# It is possible to fall back to a static IP if DHCP fails:
# define static profile
# profile static_eth0
# static ip_address=192.168.1.23/134
# static routers=192.168.1.1
# static domain_name_servers=192.168.1.1

# fallback to static profile on eth0
# interface eth0
# fallback static_eth0

# 15 / 01 / 2020 raspberry.org/forums/viewtopic.php?t=157250

	 interface wlan0
	 inform 192.168.1.134
	 static routers=192.168.1.1
	 static domain_name_servers=8.8.8.8 8.8.4.4
wpa supplicant

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
ctrl_interface=/var/run/wpa_supplicant
# ctrl_interface_group=0
update_config=1
country=IT

network={
        ssid="Casa Di Iorio_EXT"
        psk="@(QwErTy)"
        proto=WPA2
}
interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d


DirkS
Posts: 10086
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 6:01 pm

Remove
ctrl_interface=/var/run/wpa_supplicant
and the 'proto' line from wpa_supplicant.conf and reboot

User avatar
pi-anazazi
Posts: 610
Joined: Fri Feb 13, 2015 9:22 pm
Location: EU

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 6:07 pm

Casa di Iirio? Sounds nice!

https://www.booking.com/hotel/it/casa-d ... schia.html

Would you mind changing the password for your wifi after posting it here?
Kind regards

anazazi

giovangiuseppe
Posts: 5
Joined: Wed Jan 15, 2020 9:01 pm

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 6:33 pm

pi-anazazi wrote:
Thu Jan 16, 2020 6:07 pm
Casa di Iirio? Sounds nice!

https://www.booking.com/hotel/it/casa-d ... schia.html

Would you mind changing the password for your wifi after posting it here?
I know Ischia i love there but is not my house XD

giovangiuseppe
Posts: 5
Joined: Wed Jan 15, 2020 9:01 pm

Re: SSH not work with Wi-Fi

Thu Jan 16, 2020 7:08 pm

DirkS wrote:
Thu Jan 16, 2020 6:01 pm
Remove
ctrl_interface=/var/run/wpa_supplicant
and the 'proto' line from wpa_supplicant.conf and reboot
nothing has changed: c

Return to “Troubleshooting”