mihau
Posts: 8
Joined: Mon Dec 17, 2012 3:30 pm

Setting up a printer

Mon Dec 17, 2012 3:32 pm

Have someone tried to install a printer? No matter how I installed the hplip (from the repo, executable from the official page, even compiled myself with appropriate setting) I still cannot print anything. The printer itself (HP LaserJet Professional p1102) seems to install without any problems, but it won't print. Neither with a hpcups driver nor a hpijs driver.
What I've found out (from the error log):
D [17/Dec/2012:15:24:04 +0100] [Job 31] sh: 1: hpijs: not found
D [17/Dec/2012:15:24:04 +0100] [Job 31] GPL Ghostscript 9.05: Can't start ijs server "hpijs"

However, the hpijs has been installed and is present in the system.

The printer works fine with Debian Squeeze (6.0.6) on my other machine.

mihau
Posts: 8
Joined: Mon Dec 17, 2012 3:30 pm

Re: Setting up a printer

Mon Dec 17, 2012 10:42 pm

Ok, so I compiled latest hplip with hpijs support. Now it can 'print'. EVerything seems ok, but the printer doesn't even react. No errors in log, it's just like the files are going into the ether.

bteeter
Posts: 40
Joined: Tue Sep 04, 2012 7:16 pm

Re: Setting up a printer

Mon Dec 17, 2012 11:16 pm

just install cups which is a standard unix/linux printing system.

apt-get install cups

Bob Teeter

mihau
Posts: 8
Joined: Mon Dec 17, 2012 3:30 pm

Re: Setting up a printer

Mon Dec 17, 2012 11:23 pm

I have just removed everything associated with hplip, removed the printer, added new printer via CUPS and set the driver to Foomatic/foo2zjs-z2. And it worked!

User avatar
daremick
Posts: 11
Joined: Mon Dec 17, 2012 5:09 am

Re: Setting up a printer

Tue Dec 18, 2012 5:07 am

mihau wrote:I have just removed everything associated with hplip, removed the printer, added new printer via CUPS and set the driver to Foomatic/foo2zjs-z2. And it worked!

you said "added new printer" what was the new printer model? Or did you mean you just re-installed the 1102w?

mihau
Posts: 8
Joined: Mon Dec 17, 2012 3:30 pm

Re: Setting up a printer

Tue Dec 18, 2012 10:17 am

Reinstalled.

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 11 guests