RPi doesn't boot after backpowering

8 posts
by walor » Sun Dec 16, 2012 8:35 pm

I wanted to use a powered USB hub with my RPi and it seems I did what is described here as back-powering because I first plugged in the powered USB hub before inserting the normal power cable. Unfortunately, then I also plugged in the normal USB power cable and since then even without everything but SD card and power cable the RPi doesn't boot anymore.
The red PWR LED is on but nothing else happens. The F3 fuse gets incredibly hot and between the points TP1 and TP2 I only measure 3.8V instead of 4.8V with another RPi and the same power supply.
I already waited more than 24h to let the F3 fuse come back but it simply doesn't work. :cry:
Any ideas how to bring back my first RPi?

Thanks in advance!
Posts: 3
Joined: Sun Dec 16, 2012 7:43 pm
by dknute » Mon Dec 17, 2012 1:25 pm
You need to run a few more tests to pinpoint the problem.

First, measure the resistance of the input polyfuse - with power disconnected of course. It should be less than 200 miliohms. Is it F3 that gets hot, or D17 diode maybe?
Try to measure the voltage your power supply gives when not under load, though it's a bit tricky with that small USB connector. Make sure it's not over 5.5V.
Posts: 57
Joined: Thu Nov 08, 2012 9:05 pm
by walor » Mon Dec 17, 2012 2:47 pm
Thanks so far! :)
My multimeter is not that sensitive but for the input polyfuse I can measure 0.2...0.4 ohms but the cables without anything already display 0.1 ohms. So, i don't know about the first point.
What I can say is that it's for sure F3 that gets hot. D17 gets warm, too, but I can burn my finger at F3 just after 20 seconds and D17 is still at room temperature then.
I didn't find a way to measure voltage from a USB plug (not to mention the micro USB) but I tried three different power supplies and none of them worked.
Any other ideas or further tipps?
Posts: 3
Joined: Sun Dec 16, 2012 7:43 pm
by dknute » Mon Dec 17, 2012 3:24 pm
Too bad about that meter since 0.2 could still be acceptable but 0.4 is not. The way F3 is supposed to work is to either let the current through (without much voltage drop hopefully, hence the low resistance) or pretty much not let it at all when tripped.

It's one of two options:
1) Your F3 is faulty and has too high resistance that causes it drop too much voltage (but not trip). This drop is of course converted into waste heat as power is dissipated.
2) The Pi is fried and has internal short-circuit somewhere, but not big enough for the polyfuse to trip (again, maybe because it's faulty).

If it's 1 then just desolder F3, or just solder a piece of wire on top of it to short it permanently. This will fix the problem at the cost of not having a fuse anymore but I suppose you wouldn't be asking here if you had a replacement :) Now, if it's 2 and you do that, the Pi will most likely end up smoking but then again if it's already fried so what. It's not working now anyway.

Fell free to get a second opinion though :) Oh, and you can try by-passing F3 for a short time without soldering, just cover it with a wire or tinfoil and clip it with something.
Posts: 57
Joined: Thu Nov 08, 2012 9:05 pm
by Burngate » Mon Dec 17, 2012 5:04 pm
I'd also be wondering how what you did, plugging the powered hub in first before the normal USB power cable, caused the Pi to fry.
Even back-powering from the hub combined with powering normally shouldn't cause damage - both sources should only be giving 5v ± 0.25v, and neither should object if the one gives out more than the other.

You've tried the power supply with another Pi and seems okay. I would be very dubious about your hub
User avatar
Posts: 4752
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK
by Dilligaf » Tue Dec 18, 2012 12:24 am
Since it happened when you plugged something into the usb inspect the usb connectors for bent pins or something shorting them internally.
Posts: 283
Joined: Wed May 23, 2012 6:48 pm
by mahjongg » Tue Dec 18, 2012 1:16 am
re-burn your sd-card, its possible that you might have damaged some files needed for booting.
User avatar
Forum Moderator
Forum Moderator
Posts: 9154
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands
by walor » Tue Dec 18, 2012 5:38 am
Thank you all! :)

@mahjongg, @Dilligaf:
As the same SD cards runs fine with another Pi, I think it the files should be without any error. The usb connectors look fine, too. So probably no error here?

I don't know, maybe the voltages added up or something? I only know that this is what I did when the Pi died/fried. The hub works fine with my laptop (powered) and (unpowered) with another Pi (didn't want to try it powered again). I suppose that the hub's power supply may not provide 700mA, so the backpowering failed maybe, but unfortunately I didn't look for that.

Maybe I'll look for someone else with a better multimeter.
Anyways, I can't cause the F3 of the other Pi to get so hot (with or without SD card or anything else I tried), so I suppose that it's broken on the dead Pi. I think I'll try to short it later today as I agree with you that I have nothing to lose. :(
Posts: 3
Joined: Sun Dec 16, 2012 7:43 pm