User avatar
dandoe54
Posts: 5
Joined: Fri Nov 01, 2019 11:06 pm

Kodi with Netflix on Raspbian 10 Buster (Pi 4)

Mon Nov 11, 2019 6:29 pm

Hi !

It took me a moment to make Netflix work on my Rasbian 10 Buster with Kodi (Pi 4)

I followed some topics on this forum without succes

The first part was Ok

Code: Select all

sudo apt-get install kodi
sudo apt-get install kodi-peripheral-joystick kodi-pvr-iptvsimple kodi-inputstream-adaptive kodi-inputstream-rtmp
Then I downloaded and setup the add-on for Kodi

https://github.com/castagnait/repositor ... -1.0.0.zip

Open Kodi

> Add-ons tab
> Install "add from a zip file"

Choose "repository.castagnait-1.0.0.zip" from your hard disk

But, after install, the add-on always crashed at boot with this entry in the log file

Code: Select all

2019-11-11 18:18:06.498 T:2525044944   ERROR: [plugin.video.netflix (2)] Traceback (most recent call last):
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/addon.py", line 109, in <module>
                                                route(filter(None, g.PATH.split('/')))
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/addon.py", line 50, in lazy_login_wrapper
                                                return func(*args, **kwargs)
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/addon.py", line 70, in route
                                                player.play(pathitems=pathitems[1:])
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/common/videoid.py", line 284, in wrapper
                                                return func(*args, **kwargs)
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/common/misc_utils.py", line 236, in timing_wrapper
                                                return func(*args, **kwargs)
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/navigation/player.py", line 57, in play
                                                list_item = get_inputstream_listitem(videoid)
                                              File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/navigation/player.py", line 103, in get_inputstream_listitem
                                                raise InputstreamError('inputstream.adaptive is not available')
                                            InputstreamError: inputstream.adaptive is not available
2019-11-11 18:18:08.276 T:2972650592   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.netflix/play/movie/80130625/]
I've finally found that what was missing was this library

Code: Select all

pip install --user pycryptodomex
Hope it can help somebody else.

Best regards

Return to “Troubleshooting”