Biking1408
Posts: 4
Joined: Sat Nov 09, 2019 4:21 pm

Raspberry 2B not working with 2k screen

Sat Nov 09, 2019 5:00 pm

Hello,

I’m working on a project of making an 3d printer with my old raspberry pi 2 model B . I purchased following 2k screen from aliexpress:
https://www.aliexpress.com/item/3281354 ... 4c4dcx2Llx

I tested it with my laptop and it works perfectly. However when I connect it to the Pi, there was nothing display on screen. When I tried to add “hdmi_safe=1” to the /boot/config.txt but the result still the same. This is the output of “tvservice -s”:
state 0xa [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive
I also tried to uncomment some option in config.txt file like “hdmi_force_hotplug”, change “hdmi_mode” and “hdmi_group” but nothing changed. Only when I add “ hdmi_ignore_edid=0xa5000080”, the output of “tvservice -s” change to 1920 * 1080 but still no thing display on screen.

Can anyone help me with this problem?

Thank you very much.

W. H. Heydt
Posts: 10998
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Raspberry 2B not working with 2k screen

Sun Nov 10, 2019 3:19 am

If I'm reading that listing correctly, that's not a "2K" (i.e. 1920x1080) screen. It's 2560x1440.

Biking1408
Posts: 4
Joined: Sat Nov 09, 2019 4:21 pm

Re: Raspberry 2B not working with 2k screen

Sun Nov 10, 2019 4:02 am

Hi Heydt,
Yes the resolution of the screen is 1440x2560, I just used the info like the Aliexpress link.
One more info, when I connect the Pi to my samsung monito via hdmi to vga adapter, it can output image.
Do you have any idea about this?

trejan
Posts: 734
Joined: Tue Jul 02, 2019 2:28 pm

Re: Raspberry 2B not working with 2k screen

Sun Nov 10, 2019 4:09 am

The Pi 2 doesn't officially support 2K screens. You need to force it with a custom resolution in /boot/config.txt. See https://github.com/area515/Photonic3D/issues/286 Refresh rate suffers once you go higher than full HD resolutions but if you're using this in a 3D printer then that shouldn't matter.

W. H. Heydt
Posts: 10998
Joined: Fri Mar 09, 2012 7:36 pm
Location: Vallejo, CA (US)

Re: Raspberry 2B not working with 2k screen

Sun Nov 10, 2019 5:45 am

trejan wrote:
Sun Nov 10, 2019 4:09 am
The Pi 2 doesn't officially support 2K screens.
Excuse me? Pis--all the way back to the original Model B have supported standard "2K", aka 1920x1080 aka 1080p60. The critical point here is that 2560x1440 is *not* "2K".

trejan
Posts: 734
Joined: Tue Jul 02, 2019 2:28 pm

Re: Raspberry 2B not working with 2k screen

Sun Nov 10, 2019 5:57 am

W. H. Heydt wrote:
Sun Nov 10, 2019 5:45 am
Excuse me? Pis--all the way back to the original Model B have supported standard "2K", aka 1920x1080 aka 1080p60. The critical point here is that 2560x1440 is *not* "2K".
No. 2K is a label. 1920x1080 is Full HD and not considered to be 2K even though 1920 is close to 2000. 2K is officially 2048x1080 but 2560x1440 resolution monitors are generally referred to as 2K as well. Blame DCI for this naming scheme and monitor/computer manufacturers for muddying it even more.

My statement that the Pi 2 doesn't officially support 2K screens still stands.

Biking1408
Posts: 4
Joined: Sat Nov 09, 2019 4:21 pm

Re: Raspberry 2B not working with 2k screen

Mon Nov 11, 2019 2:37 am

trejan wrote: The Pi 2 doesn't officially support 2K screens. You need to force it with a custom resolution in /boot/config.txt. See https://github.com/area515/Photonic3D/issues/286 Refresh rate suffers once you go higher than full HD resolutions but if you're using this in a 3D printer then that shouldn't matter.
I have added some custom resolution but there is no change, may be because I missed the hdmi_timing setting, I will give it a try with the link you provide. Thanks.

Biking1408
Posts: 4
Joined: Sat Nov 09, 2019 4:21 pm

Re: Raspberry 2B not working with 2k screen

Mon Nov 11, 2019 4:39 pm

So I tried these setting and it worked:

Code: Select all

overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0
#disable_overscan=1
hdmi_drive=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87
#60Hz
hdmi_pixel_freq_limit=206000000
hdmi_timings=1440 0 150 5 5 2560 0 3 1 9 0 0 0 60 0 205210000 1
max_framebuffer_width=1440
max_framebuffer_height=2560
display_rotate=0
framebuffer_width=1440
framebuffer_height=2560
At first I confused a little bit about the width and height and the result is weird, the screen was separated into many 3 regions. After that I swapped the width value and height value and got the correct output.

Thank you very much for your support.

Return to “General discussion”