Posts: 1
Joined: Tue Oct 08, 2019 11:00 am

Lipo help

Tue Oct 08, 2019 11:04 am

Hi, I'm hoping someone can help me understand why a lipo isn't working with my pi zero and waveshare e-ink display.

The parts I'm using are:

1800 mah lipo:
1000 mah lipo:
boost converter:
charging module:

I'm trying to get the 1800mah lipo working, I have tried every configuration I an think of:
- Direct to pins behind USB
- lipo -> charge module, charge module -> pins behind USB
- lipo -> charge module, charge module -> boost controller -> pins behind usb (both 3.5 and 5v)
- lipo -> boost controller -> pins behind USB (both 3.5 and 5v)
- lipo -> boost controller -> header pins (5v) (like this: ... 1459181848)

none of these worked.
The 1000mah lipo however works both direct to pins behind USB or using charge circuit.

I'm clearly missing something here and hoping someone can help?

Posts: 9724
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Lipo help

Tue Oct 08, 2019 3:33 pm


Sounds like you need to do some basic fault finding with a meter,

start by measuring the input voltage on the buck converter with just the battery connected, if it looks ok , move on the the output of the buck converter, and see if that's at 5.1 volts, then try connecting your pi and see if the output voltage still reads 5v.

continue like this testing as you boot the pi and then adding more hardware till you find were the voltage drops off .

remember only make or break connections with the power off.

I assume of course that you have checked the battery is charged.
We want information… information… information no help
The use of crystal balls & mind reading are not supported

Return to “Other projects”