fti74
Posts: 1
Joined: Fri Sep 13, 2019 6:25 pm

Raspberry pi 4 | Unable to force sound through jack

Fri Sep 13, 2019 9:35 pm

Hello,

on one of my raspberry PI 4, I can't get audio through the 3.5mm jack (I don't know if 'm getting any audio through DMI)
I have forced the audio to go through the jack (using raspi-config):

Code: Select all

sudo amixer cset numid=3 
numid=3,iface=MIXER,name='Master Playback Volume'
  ; type=INTEGER,access=rw------,values=1,min=0,max=65536,step=1
  : values=1
I can't get any audio from the usual apps: VLC, Chromium...

Sound works fine from another PI and also when using:

Code: Select all

omxplayer -o local sample.mp3

As I don't hear a thing with:

Code: Select all

omxplayer sample.mp3
this means I can rule out any cable/speaker issue.

I have checked with alsa-mixer, the volume isn't set to 0 (same with the desktop widget).

I have to admit I can't think of anything else.

Thanks

User avatar
DougieLawson
Posts: 39120
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Raspberry pi 4 | Unable to force sound through jack

Fri Sep 13, 2019 11:21 pm

Run sudo rpi-update; sudo reboot. There's a fix for analog audio in today's update.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Return to “Troubleshooting”