droidgull
Posts: 10
Joined: Fri Oct 06, 2017 7:40 pm

Zero W + ZeroCam + MotionEyeOS not working

Tue Sep 10, 2019 7:13 pm

When I test my ZeroCam from PiHut with raspian and raspistill it's working.
With MotionEyeOS all I get is a spinning symbol, no picture.
Is the ZeroCam compatible with MotionEyeOS?
Last edited by droidgull on Wed Sep 11, 2019 8:27 pm, edited 1 time in total.

User avatar
DougieLawson
Posts: 36312
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Zero W + ZeroCam + MotionEye not working

Tue Sep 10, 2019 10:12 pm

You need to load bcm2835-v4l2 to access the camera with Motion.

Add that to /etc/modules to get it loaded at boot time. Use sudo modprobe bcm2835-v4l2 to get it loaded now (without a reboot).
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

droidgull
Posts: 10
Joined: Fri Oct 06, 2017 7:40 pm

Re: Zero W + ZeroCam + MotionEyeOS not working

Wed Sep 11, 2019 8:30 pm

I realize now that I am using MotionEyeOS, not MotionEye. First post updated.

From the message.log:
Sep 11 22:11:01 meye-bc0efe3e user.err motion: [1:ml1:Camera1] [ERR] [VID] vid_start: V4L2 device failed to open
Sep 11 22:11:01 meye-bc0efe3e user.warn motion: [1:ml1:Camera1] [WRN] [ALL] motion_init: Could not fetch initial image from camera
Sep 11 22:11:01 meye-bc0efe3e user.warn motion: [1:ml1:Camera1] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
Sep 11 22:11:10 meye-bc0efe3e user.warn motion: [1:ml1:Camera1] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
Sep 11 22:11:10 meye-bc0efe3e user.err motion: [1:ml1:Camera1] [ERR] [VID] v4l2_device_capability: Device does not support capturing.

droidgull
Posts: 10
Joined: Fri Oct 06, 2017 7:40 pm

Re: Zero W + ZeroCam + MotionEyeOS not working

Sun Nov 10, 2019 2:12 pm

Updated to version 20190911, and now everything works. :D

Return to “Camera board”