Posts: 25
Joined: Mon Jul 16, 2012 10:35 pm

.Net Core Avalonia UI Frozen

Tue Sep 10, 2019 5:32 am

I have tried this two different ways, firstly starting here:


And ending up here:


I am building this using .Net Core 2.2.6 (2.2.401 SDK), VS Community 2019. I tried with the .Net Core installed on the Raspberry Pi and also with publishing as a self-contained project. The application runs but the interface is unresponsive. In both examples above I can't interact with the on-screen controls, they are completely non-responsive. In the case of the hello world example I setup console output as well as SerilogLogger, the program starts up and there are no errors reported, console does output so the application does start up. If I minimise the app then restore it, the app interface is garbled - as in the window transition is repeated all across itself. If I then maximise it returns to normal, likewise when it is restored again.

I first tried on Raspbian Stretch, the controls did not render correctly, they just rendered squashed, text didn't render at all and it is unresponsive to any clicks. On Buster, it renders nicely and like Stretch is unresponsive to user interaction. Both applications run just fine in the Windows build environment. At one point I even published the project from source on the Raspi using an installed SDK and that did not make any difference from the Windows published application. Between tests of having the Core runtime/SDK installed/not installed I have been re-writing a completely fresh Raspbian image, currently concentrating on Buster since it at least displays the UI.

Since everyone else has this working I must be doing something pretty fundamentally wrong, any ideas??

Return to “Other programming languages”