johnny49r
Posts: 4
Joined: Mon Aug 26, 2019 1:54 am

RPi 4 gpio-poweroff not working

Mon Sep 02, 2019 12:05 pm

Hi,
1st post here.
I want to implement some form of safe power removal on the RPi 4 and I thought I could make use of the GPIO POWEROFF overlay feature.
I have read that this works on the RPi 3/3B but does not work on my RPi 4.
My environment:
RPi 4, 2GB ram.
Installed latest <recovery> bootloader rc3.3 which keeps the 3.3V rail powered after shutdown and enables WAKE ON GPIO.
I am running the current version of Raspbian.
In the /boot/config.txt I enable dtoverlay gpio-poweroff.
When I issue a shutdown or halt -p (same thing I believe) I get the following message:

Code: Select all

reboot: Power Down
Kernel panic - not syncing: Attempted to kill init! exitcode 0x00000000
CPU: 0 PID: 1 Comm systemd-shutdow Taintcd: G  WC 4.19.66-v71* #1253
etc...etc...
end Kernel panic
I have tried different gpio pins and states (active_low, active_high) but the result is the same.
Is this a bug in the bootloader/Raspbian or something I am not doing correctly?
Thank you

Return to “General discussion”