Ken K
Posts: 9
Joined: Sat Jan 05, 2019 9:47 pm

No GUI after buster upgrade

Tue Aug 20, 2019 5:23 pm

This is the first upgrade I have done since I started with RPi. Going from the latest stretch to buster on a 3b+. Tried 2 different times following different tutorials. 1 used "apt full-upgrade" and the other used "apt dist-upgrade". Both completed without errors and I verified the kernel and OS had been upgraded. However, when I rebooted, it went to the command line instead of the GUI. I tried changing the boot options and resolutions with raspi-config but nothing has worked. The version of stretch I upgraded was a full version with GUI. Although I usually run this machine headless, I used an HDMI monitor and dedicated keyboard/mouse for the upgrade.

Just as a test, I installed a fresh copy of buster and all is fine so I know it's not a HW configuration issue.

Any help will be greatly appreciated.

Ken

fruitoftheloom
Posts: 26265
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: No GUI after buster upgrade

Tue Aug 20, 2019 5:45 pm

Ken K wrote:
Tue Aug 20, 2019 5:23 pm
This is the first upgrade I have done since I started with RPi. Going from the latest stretch to buster on a 3b+. Tried 2 different times following different tutorials. 1 used "apt full-upgrade" and the other used "apt dist-upgrade". Both completed without errors and I verified the kernel and OS had been upgraded. However, when I rebooted, it went to the command line instead of the GUI. I tried changing the boot options and resolutions with raspi-config but nothing has worked. The version of stretch I upgraded was a full version with GUI. Although I usually run this machine headless, I used an HDMI monitor and dedicated keyboard/mouse for the upgrade.

Just as a test, I installed a fresh copy of buster and all is fine so I know it's not a HW configuration issue.

Any help will be greatly appreciated.

Ken

You have been misinformed, see the Official Blog, which states a release update is not recommended, though gives you the various steps:

https://www.raspberrypi.org/blog/buster ... -raspbian/
The information is out there....you just have to let it in.

My other Linux machines: ChromeBox
https://www.aliexpress.com/item/32966393971.html
& Stone Desktop Intel CoreDuo circa 2010

Ken K
Posts: 9
Joined: Sat Jan 05, 2019 9:47 pm

Re: No GUI after buster upgrade

Wed Aug 21, 2019 10:06 pm

Thanks for the reference. Following the procedure listed in that blog post worked for me.

francknos
Posts: 7
Joined: Wed Nov 15, 2017 11:03 am

Re: No GUI after buster upgrade

Sun May 24, 2020 7:46 pm

Hi, I have the same problem.
I have done every thing witjout problem. But my pi start only in consol no gui ?;?
Someone can help me ?
:mrgreen: Francknos :mrgreen:

francknos
Posts: 7
Joined: Wed Nov 15, 2017 11:03 am

Re: No GUI after buster upgrade

Sun May 24, 2020 8:33 pm

I found solution working for me !
Just put

Code: Select all

sudo apt-get install xserver-xorg-video-fbturbo
Found on this form https://raspberrypi.stackexchange.com/a/101085/120150

I only write one line and my gui revive !
:mrgreen: Francknos :mrgreen:

Return to “General discussion”