LordGrayHam
Posts: 3
Joined: Thu Jun 20, 2013 5:45 pm

Omxplayer not installed?

Fri Aug 16, 2019 1:18 pm

Hey guys,
trying to install displaycameras on my Pi 3B+. It requires omxplayer. It's supposed to come preinstalled on raspbian buster lite, as I've already done this in the past with another identical Pi, but today when trying to set this one up, it seems omxplayer is not installed. i tried manually installing it with "sudo apt-get install omxplayer", and it prompts me that it will take up about 400MB of disk space, I hit yes, and i get this:
Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpango-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
Err:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpangoft2-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
Err:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpangocairo-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
i've tried running apt-get update and upgrade, and there's nothing to update or upgrade. The pi has internet access because I was able to do a github download on it, and i tried pinging www.google.com just to make sure. Anything I'm doing wrong?
Cheers!

User avatar
rpdom
Posts: 14684
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Omxplayer not installed?

Fri Aug 16, 2019 4:51 pm

It's possible you tried to install at a time when the server you are using was in the middle of an update.

If you get message like that in future, wait an hour or two, then run sudo apt-get update again and then retry the install.

I can see you were trying to install libpango-1.0-0 version 1.42.4-6 and the current version is 1.42.4-7~deb10u1, so it has been updated at some point.

LordGrayHam
Posts: 3
Joined: Thu Jun 20, 2013 5:45 pm

Re: Omxplayer not installed?

Sat Aug 17, 2019 3:30 pm

Still having the same issue today.
I have run both update and upgrade, nothing seems to need an update?
I still get the same 404 error.

Here is the full readout of when i run "sudo apt-get install omxplayer":
sudo apt-get install omxplayer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
fontconfig fontconfig-config fonts-dejavu-core libaacs0 libaom0 libavcodec58
libavformat58 libavutil56 libbdplus0 libbluray2 libcairo2 libchromaprint1
libcodec2-0.8.1 libcroco3 libdatrie1 libdrm-common libdrm-etnaviv1
libdrm-nouveau2 libdrm-radeon1 libdrm2 libfontconfig1 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgl1 libgl1-mesa-dri
libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgme0 libgraphite2-3 libgsm1
libharfbuzz0b libjbig0 libllvm6.0 libmp3lame0 libmpg123-0 libogg0
libopenjp2-7 libopenmpt0 libopus0 libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libpixman-1-0 librsvg2-2 librsvg2-common libsensors-config
libsensors5 libshine3 libsnappy1v5 libsoxr0 libspeex1 libssh-gcrypt-4
libswresample3 libthai-data libthai0 libtheora0 libtiff5 libtwolame0
libva-drm2 libva-x11-2 libva2 libvdpau-va-gl1 libvdpau1 libvorbis0a
libvorbisenc2 libvorbisfile3 libvpx5 libwavpack1 libwebp6 libwebpmux3
libx11-xcb1 libx264-155 libx265-165 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
libxcb-present0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0
libxdamage1 libxfixes3 libxrender1 libxshmfence1 libxvidcore4 libxxf86vm1
libzvbi-common libzvbi0 mesa-va-drivers mesa-vdpau-drivers va-driver-all
vdpau-driver-all
Suggested packages:
libbluray-bdj opus-tools librsvg2-bin lm-sensors speex
The following NEW packages will be installed:
fontconfig fontconfig-config fonts-dejavu-core libaacs0 libaom0 libavcodec58
libavformat58 libavutil56 libbdplus0 libbluray2 libcairo2 libchromaprint1
libcodec2-0.8.1 libcroco3 libdatrie1 libdrm-common libdrm-etnaviv1
libdrm-nouveau2 libdrm-radeon1 libdrm2 libfontconfig1 libgdk-pixbuf2.0-0
libgdk-pixbuf2.0-bin libgdk-pixbuf2.0-common libgl1 libgl1-mesa-dri
libglapi-mesa libglvnd0 libglx-mesa0 libglx0 libgme0 libgraphite2-3 libgsm1
libharfbuzz0b libjbig0 libllvm6.0 libmp3lame0 libmpg123-0 libogg0
libopenjp2-7 libopenmpt0 libopus0 libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libpixman-1-0 librsvg2-2 librsvg2-common libsensors-config
libsensors5 libshine3 libsnappy1v5 libsoxr0 libspeex1 libssh-gcrypt-4
libswresample3 libthai-data libthai0 libtheora0 libtiff5 libtwolame0
libva-drm2 libva-x11-2 libva2 libvdpau-va-gl1 libvdpau1 libvorbis0a
libvorbisenc2 libvorbisfile3 libvpx5 libwavpack1 libwebp6 libwebpmux3
libx11-xcb1 libx264-155 libx265-165 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
libxcb-present0 libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0
libxdamage1 libxfixes3 libxrender1 libxshmfence1 libxvidcore4 libxxf86vm1
libzvbi-common libzvbi0 mesa-va-drivers mesa-vdpau-drivers omxplayer
va-driver-all vdpau-driver-all
0 upgraded, 97 newly installed, 0 to remove and 0 not upgraded.
Need to get 282 kB/39.8 MB of archives.
After this operation, 438 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpango-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
Err:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpangoft2-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
Err:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf libpangocairo-1.0-0 armhf 1.42.4-6
404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbia ... _armhf.deb 404 Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
I was under the impression that raspbian comes with omxplayer preinstalled, but maybe not on the "lite" distro? Is it normal for the repo servers to be down for this long?

DirkS
Posts: 9871
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Omxplayer not installed?

Sat Aug 17, 2019 4:01 pm

LordGrayHam wrote:
Sat Aug 17, 2019 3:30 pm
Still having the same issue today.
Please re-read @rpdom's post... You need to run 'sudo apt-get update' (or 'sudo apt update') before trying to install any program. Your package cache is not up to date

LordGrayHam
Posts: 3
Joined: Thu Jun 20, 2013 5:45 pm

Re: Omxplayer not installed?

Sat Aug 17, 2019 4:11 pm

So it turns out the system clock was the issue, even though I set it in raspi-config, I had to manually set it myself. Thanks for help.

Return to “Troubleshooting”