Z0eff
Posts: 1
Joined: Fri Jul 12, 2019 8:03 pm

Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Fri Jul 12, 2019 9:08 pm

There's not even so much as a peep from the syslog either. Tried all 4 USB ports on the RBPi. From what I understand, it should show up as /dev/ttyACM0 or /dev/ttyACM1 if there's such a device already, but there's nothing. However, the LED does light up and does it's Yellow-Red-Blue routine which from what I'm reading is normal. It's getting power from the USB port at least.

I've plugged it into a windows machine to see if it's detected there, and it immediately gets assigned a COM port in the Device Manager, so it does seem to work. Plugging in a random USB memory stick into the Raspberry Pi 4 shows up immediately and makes syslog spit out information about it, so the USB ports are functional.

Does anybody have any idea what might be the issue here?

Here's a screenshot of the output of some commands while both the Aeotec Z-Stick and USB memory sticks are inserted:
USB_Devices_list_with_USBstorage_and_Z-Stick_plugged_in.png
USB_Devices_list_with_USBstorage_and_Z-Stick_plugged_in.png (138.3 KiB) Viewed 2979 times
Here is it showing up fine in Windows:
Z-Stick_showing_up_in_Windows.png
Z-Stick_showing_up_in_Windows.png (4.27 KiB) Viewed 2979 times

kendaop
Posts: 3
Joined: Sat Jul 13, 2019 5:08 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Sat Jul 13, 2019 5:13 pm

I'm having this issue too. The Z-Stick works fine on my RPi3.

hosereh
Posts: 8
Joined: Mon Jan 22, 2018 2:12 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Tue Jul 30, 2019 1:56 pm

I had the same issue - until I plugged the stick into the USB ports directly next to the ethernet jack.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 28371
Joined: Sat Jul 30, 2011 7:41 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Tue Jul 30, 2019 2:19 pm

Please read this issue for details on this non-compliant device.

https://github.com/raspberrypi/linux/issues/3027
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

mattiasPie
Posts: 1
Joined: Sun Aug 25, 2019 8:00 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Sun Aug 25, 2019 8:04 pm

Hi

I have the exact same problem. However mine was working for a week until I rebooted my PI yesterday and I have been unable to get it working since.
Strange that it was working for a while and then stoped.
As a workaround I have ordered a USB hub from Amazon with 5-7 days shipping.

tunish
Posts: 1
Joined: Tue Apr 21, 2020 5:38 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Tue Apr 21, 2020 5:39 pm

Hi,
Any news for this. Is there going to be any fix for this issue with Rpi4b model?
It works correctly with 3b+..

User avatar
rpdom
Posts: 18402
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Tue Apr 21, 2020 7:42 pm

tunish wrote:
Tue Apr 21, 2020 5:39 pm
Hi,
Any news for this. Is there going to be any fix for this issue with Rpi4b model?
It works correctly with 3b+..
Did you read the comments on the link that jamesh posted?
That is where you will see any updates.
Unreadable squiggle

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 28371
Joined: Sat Jul 30, 2011 7:41 pm

Re: Aeotec Z-Stick not showing up in /dev/ (RBPi 4 Model B)

Wed Apr 22, 2020 7:30 am

tunish wrote:
Tue Apr 21, 2020 5:39 pm
Hi,
Any news for this. Is there going to be any fix for this issue with Rpi4b model?
It works correctly with 3b+..
No, this is a problem with the wave not adhering to the USB electrical standard, not the pi4 usb controller.

Pi3 uses a different controller.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

Return to “Troubleshooting”