rosswesleyporter
Posts: 10
Joined: Tue Sep 22, 2015 3:53 am

vlc-nox package no longer available?

Thu Jul 11, 2019 5:37 am

Is the vlc-nox package no longer available? I just tried to install on my new Pi 4 with Buster and it suggests that I install the vlc-bin package instead, details below.

I tried vlc-bin but it doesn't seem to be a drop-in replacement for my specific needs - needs to run headless and work with Python bindings to vlc. I've been using vlc-nox for this for years now. I don't need the most recent vlc bits. The vlc-nox package that was there a few months ago would probably be just fine. But I don't know how to apt-get a package that may have been obsoleted.

So far, my googling has been fruitless. Any suggestions appreciated. Thanks.

Code: Select all

$ sudo apt-get install vlc-nox
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vlc-nox is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  vlc-bin

E: Package 'vlc-nox' has no installation candidate

plugwash
Forum Moderator
Forum Moderator
Posts: 3418
Joined: Wed Dec 28, 2011 11:45 pm

Re: vlc-nox package no longer available?

Thu Jul 11, 2019 5:47 am

vlc-nox in stretch was a transitional package depending on vlc-bin and vlc-plugin-base, in buster the transitional package is gone but vlc-bin and vlc-plugin-base are still available.

-Scripted-
Posts: 1
Joined: Sat Sep 15, 2018 6:51 pm

Re: vlc-nox package no longer available?

Fri Jul 12, 2019 12:21 am

Yes, I was having the same problem also while trying to run AlexaPi(I am a total beginner). I get that vlc-bin can replace vlc-nox, because it says so in the terminal, but how exactly would I replace it? Is there a certain line of code I have to run?

rosswesleyporter
Posts: 10
Joined: Tue Sep 22, 2015 3:53 am

Re: vlc-nox package no longer available?

Fri Jul 12, 2019 5:00 pm

Pugwash, thanks for the clarification. I'll seek to make vlc-bin work with Python bindings. Scripted, once I get it to work, I will reply again.

rosswesleyporter
Posts: 10
Joined: Tue Sep 22, 2015 3:53 am

Re: vlc-nox package no longer available?

Fri Jul 12, 2019 6:02 pm

I installed vlc-bin and vlc-plugin-base. That worked!

In case anyone else is in my specific situation:
- I was using vlc-nox 2.x on stretch, controlling vlc with Python bindings (https://github.com/oaubert/python-vlc).
- I got everything working on a new Pi 4 by installing vlc-bin, and vlc-plugin-base. And switching the Python VLC bindings from the VLC 2.x bindings to the VLC 3.x bindings (both sets of bindings are in the repository above).
- One bonus of the Pi 4 / Buster setup is that USB Audio Class 2 (UAC2) devices may work now. I've been using one (Schiit Fulla 2) for the last 30 minutes or so. I'll keep testing. There is a known issue with UAC2 devices on all earlier Pi models.

Return to “Media centres”