alsamaraee
Posts: 2
Joined: Sun Jun 09, 2019 8:28 am

DPI parallel Display problem

Fri Jun 14, 2019 11:37 pm

Hello,

I connected raspberry pi 3 to a rgb parallel display via dpi GPIO. the display is 7" 800x480 18 bit. The problem is I don't have any datasheet about the display. But I could connect it and get picture with issues. The colors are right. But the picture is unstable. You can check the short video.
https://www.youtube.com/watch?v=4gFNcr-WpMw
My config.txt file has these settings

Code: Select all

#dpi configurations
dtoverlay=dpi24
overscan_left=0
#overscan_right=0
overscan_top=0
overscan_bottom=0
framebuffer_width=800
framebuffer_height=480
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=49157
#output_format = 5
#rgb_order = 0
#output_enable_mode = 0
#invert_pixel_clock = 0
#hsync_disable = 0
#vsync_disable = 0
#output_enable_disable = 1
#hsync_polarity = 0
#vsync_polarity = 0
#output_enable_polarity = 0
#hsync_phase = 0
#vsync_phase = 0
#output_enable_phase = 0

dpi_timings=800 0 60 48 88 480 0 13 3 32 0 0 0 60 0 32000000 6
Any help?

aBUGSworstnightmare
Posts: 1284
Joined: Tue Jun 30, 2015 1:35 pm

Re: DPI parallel Display problem

Sat Jun 15, 2019 2:55 pm

alsamaraee wrote: The problem is I don't have any datasheet about the display.
how can somebody else help you with this?
The only thing I can say is: your timing is wrong.

What's wrong? You need to data sheet for answering this. Do you have the part number of the display at least?

Return to “Advanced users”