Pandaxx7w7
Posts: 3
Joined: Thu Jun 13, 2019 8:34 pm

apt-get no funciona, ayuda ;/

Thu Jun 13, 2019 9:08 pm

Bueno el problema es el siguiente,
Recién acabo de instalar la última versión de raspbian en una memoria de 16gb para mí raspberry 3. que está en buenas condiciones
Y me encontré el error que cuando quiero utilizar (apt-get/wget) no funcionan.
Osea ya intenté de todo con los mirrors y todo eso pero.
Creo que el problema está en otro lugar, lo peor es que no puedo usar (sudo apt-get upgrade)
Tampoco puedo actualizar el sistema. Cuando inicia el menú de bienvenida (el primer arranque) me pide que busque actualizaciónes-
Pero no encuentra nada,

Ahora este es el error que me da al intentar usar apt-get
Aquí un ejemplo:

Code: Select all

sudo apt-get install w3m
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  git-man liberror-perl
Utilice «sudo apt autoremove» para eliminarlos.
Se instalarán los siguientes paquetes adicionales:
  libgc1c2
Paquetes sugeridos:
  w3m-img libsixel-bin w3m-el cmigemo mpv dict dictd dict-wn
Se instalarán los siguientes paquetes NUEVOS:
  libgc1c2 w3m
0 actualizados, 2 nuevos se instalarán, 0 para eliminar y 109 no actualizados.
Se necesita descargar 1.155 kB de archivos.
Se utilizarán 2.383 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf libgc1c2 armhf 1:7.4.2-8 [197 kB]
Des:1 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf libgc1c2 armhf 1:7.4.2-8 [197 kB]
Des:1 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf libgc1c2 armhf 1:7.4.2-8 [197 kB]
Des:1 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf libgc1c2 armhf 1:7.4.2-8 [197 kB]
Err:1 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf libgc1c2 armhf 1:7.4.2-8
  La suma hash difiere
  Hashes of expected file:
   - SHA256:cec784887d5c50fef7443ad00672e982249755028a371790d3409c281d2f503e
   - SHA1:4a4f10cda3445633880611cfb609d2bac4500da8 [weak]
   - MD5Sum:2bdb3dfb544d0670dd2a7df80fea2ac2 [weak]
   - Filesize:196802 [weak]
  Hashes of received file:
   - SHA256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
   - SHA1:da39a3ee5e6b4b0d3255bfef95601890afd80709 [weak]
   - MD5Sum:d41d8cd98f00b204e9800998ecf8427e [weak]
   - Filesize:0 [weak]
  Last modification reported: Tue, 31 May 2016 10:08:02 +0000
Des:2 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf w3m armhf 0.5.3-34+deb9u1 [958 kB]
Err:2 http://espejito.fder.edu.uy/raspbian/raspbian stretch/main armhf w3m armhf 0.5.3-34+deb9u1
  La suma hash difiere
  Hashes of expected file:
   - SHA256:bedc24008587430742639dea64fcbf2c3e4af1e6d94a35357450a12323ac6f55
   - SHA1:4ced12e6c9354792c9eea764587c5443dc1aab08 [weak]
   - MD5Sum:0125f0b0050053e9069fbaafb2d46fef [weak]
   - Filesize:957966 [weak]
  Hashes of received file:
   - SHA256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
   - SHA1:da39a3ee5e6b4b0d3255bfef95601890afd80709 [weak]
   - MD5Sum:d41d8cd98f00b204e9800998ecf8427e [weak]
   - Filesize:0 [weak]
  Last modification reported: Sat, 10 Mar 2018 22:08:04 +0000
E: Fallo al obtener http://espejito.fder.edu.uy/raspbian/raspbian/pool/main/libg/libgc/libgc1c2_7.4.2-8_armhf.deb  La suma hash difiere
   Hashes of expected file:
    - SHA256:cec784887d5c50fef7443ad00672e982249755028a371790d3409c281d2f503e
    - SHA1:4a4f10cda3445633880611cfb609d2bac4500da8 [weak]
    - MD5Sum:2bdb3dfb544d0670dd2a7df80fea2ac2 [weak]
    - Filesize:196802 [weak]
   Hashes of received file:
    - SHA256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
    - SHA1:da39a3ee5e6b4b0d3255bfef95601890afd80709 [weak]
    - MD5Sum:d41d8cd98f00b204e9800998ecf8427e [weak]
    - Filesize:0 [weak]
   Last modification reported: Tue, 31 May 2016 10:08:02 +0000
E: Fallo al obtener http://espejito.fder.edu.uy/raspbian/raspbian/pool/main/w/w3m/w3m_0.5.3-34+deb9u1_armhf.deb  La suma hash difiere
   Hashes of expected file:
    - SHA256:bedc24008587430742639dea64fcbf2c3e4af1e6d94a35357450a12323ac6f55
    - SHA1:4ced12e6c9354792c9eea764587c5443dc1aab08 [weak]
    - MD5Sum:0125f0b0050053e9069fbaafb2d46fef [weak]
    - Filesize:957966 [weak]
   Hashes of received file:
    - SHA256:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
    - SHA1:da39a3ee5e6b4b0d3255bfef95601890afd80709 [weak]
    - MD5Sum:d41d8cd98f00b204e9800998ecf8427e [weak]
    - Filesize:0 [weak]
   Last modification reported: Sat, 10 Mar 2018 22:08:04 +0000
E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get update» o deba intentarlo de nuevo con --fix-missing?
Ese es el error espero me puedan ayudar. De mientras seguire buscando la solución por mi cuenta
Si necesitan más detalles sobre algo. Avísenme y intentaré colaborar pero por ahora no encuentro solución, y gracias..

mauricioccg
Posts: 1
Joined: Thu Jun 13, 2019 11:57 pm

Re: apt-get no funciona, ayuda ;/

Fri Jun 14, 2019 12:02 am

Hola!
Hace unos minutos encontré la solución y te la comparto...
1. Modificá la lista de repositorios: sudo nano /etc/apt/sources.list
Después de probar varios, te recomiendo http://raspbian.c3sl.ufpr.br/raspbian/
2. sudo apt update
3. sudo apt upgrade (si es necesario) y listo.
Espero haberte ayudado a resolver este inconveniente.
Exitos!

spartan2
Posts: 1
Joined: Fri Jun 14, 2019 3:55 am

Re: apt-get no funciona, ayuda ;/

Fri Jun 14, 2019 3:59 am

Hola amigo, te doy la solución ya que tuve el mismo problema, el servidor de Uruguay esta caído.
Simplemente debes reemplazarlo por otro, te paso el que estoy usando y va de maravilla:

Code: Select all

sudo nano /etc/apt/sources.list
Comentas la primer linea, y agregas la linea del repositorio de brazil : deb http://mirror.ufam.edu.br/raspbian/raspbian/ stretch main contrib non-free rpi

Code: Select all

#deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
deb http://mirror.ufam.edu.br/raspbian/raspbian/ stretch main contrib non-free rpi

Pandaxx7w7
Posts: 3
Joined: Thu Jun 13, 2019 8:34 pm

Re: apt-get no funciona, ayuda ;/

Fri Jun 14, 2019 8:38 pm

Pues probe como ustedes dijieron y ahora ya no me sale error,
Pero ahora nisiquiera me localiza los paquetes osea me sale

Code: Select all

sudo apt-get install 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estádo... Hecho
E: No se ha podido localizar el paquete 
Ya probé con los servidores que me dieron pero ahora sale eso alguna sugerencia? :D

Por cierto soy de Argentina, ya probé con el servidor de Argentina pero tampoco funciona

BROpi
Posts: 1
Joined: Sat Jun 15, 2019 11:48 am

Re: apt-get no funciona, ayuda ;/

Sat Jun 15, 2019 11:54 am

Hola Muchas Gracias, tenia el mismo problema para actualizar y con el cambio de servidor funciono!
Saludos desde San Juan Argentina.

Return to “Español”